Unziping causes system freeze (Fedora 27)

Yesterday I bought new SSD dedicated for linux. It’s GoodRam CX300. I installed Fedora Server with Gnome and everything worked fine, downloading with dnf, firefox and Software Centre caused no problem.
Today i wanted to set up Android Studio. Every time I try to unzip something it starts unziping but freezes the system after 3 - 5 secs.
Mouse and keyboard are still responsive (can move pointer on screen, Lock indicators change) but I can’t interact with any elemnt of the screen (can’t close windows, logout, type in terminal, open anything) and am forced to Hard Reboot.

I have never heard of this company before.

Before you unzip can you open a system monitor and view the disk activity when the unzip happens?

btw I moved your topic to Linux

Also have you used this machine with Fedora for a long enough time to know that this is not some other problem instead of the SSD? If you still have your old drive you could try doing what you are doing on that drive, and then that may point to the new SSD being at fault if your old drive works properly.

1 Like

GoodRam? more like BadRam. maybe.


I’ve used this same setup for over a year. Never had such problem.
I just tried to unzip and system froze before I could read or do anything. I am 99% sure it’s unzipping since this happens only when I unzip.
Is there any utility to check if something wrong with the drive? I don’ fancy going to shop where i bought this SSD, tell them it doesn’t work, wait for a week and get it back because they tasted it on their machine and it works :confused:

As for GoodRam, it’s the only European manufacturer of RAM and works with Toshiba and Samsung. They are much less known outside of Europe as far as I know.

edit: I havn’t really answer your question about old drive. I did use unzip and unziped things on it yesterday and everything worked fine.

Haha, you’re so funny and helpful :smile: :smile: :smile:

Do you have unzip installed? Have you tired it from the command line?

1 Like

Ahh that’s why I have not heard of it. I’m American.

As far as utilities, you can use the smartctl. Use the command

sudo smartctl -a /dev/sda | less

Yes, and I did use it with the same result.

It yields “PASSED” :confused:

That’s odd. can you run fpaste --sysinfo


Why Fedora Server out of curiosity?

I don’t see anything funny in the paste. The command line shouldn’t freeze the system either.

I doubt its the drive, but you could check by unzipping it on another drive.

Also, does it complete if you leave it? Do small zip files work?

Maybe its an AMD problem, I vaguely remember something like that before, but i might be wrong. (theres a rawhide kernel to try if you want)

1 Like

Server because I had usb with server edition for some reason and last time i checked server and WS edition are not any different besides what is included from the start and configuration for 3 or 4 things. I don’t like bundled gnome software and I find installing server edition and then installing what i want easier.

It unzips partially I think since it looks like everything is unziped but when i try to open file or run some .sh file nothing happens.

I just tried to unzip using command line from SSD1 to HDD1 and from SSD1 to SSD1 like 5 times each and it worked, but when I tried to install something from Android Studio and it started to unzip whatever it downloaded the system froze up, so I guess there is something wrong with Android Studio after all.¯\(ツ)

Although command line unzip did freeze my system earlier as well…

What command are you using to unzip or are you right-clicking + extract here?
I’m no expert, just curious.


Two things. Android studio is large. Also, how is your SSD being mounted in the fstab?

Are you using any trim commands (continuous trim could be bad fore some SSDs because bad trim implementation).
What scheduler are you using for your SSD? Are you using DeadLine?