Unstable motherboard, what do?

My old motherboard (Aorus B450I Pro Wifi) kicked the bucket recently, pretty sure there is some kind of power fault as I don’t get POST or fans spinning.

On the new motherboard, I can boot reliably, but the system crashes constantly (several times a day), randomly, and differently every time. Sometimes I get logs in dmesg, sometimes I don’t. Right now the system overall runs fine but random processes are getting segaults every once in a while. I’ve made double sure everything is seated correctly, but it’s hard to guarantee the GPU doesn’t jiggle a little bit in its socket. It passed an mprime torture test with flying colors.

I used to have a first-gen Ryzen and when I had similar problems in the past it turned out to be from a faulty CPU. Now it appears to be from a faulty motherboard.

I haven’t owned a computer case for a long time, the motherboard is currently sitting on top of the anti-static bag it came in. It’s never caused me significant problems except when something touches the board (which is not often).

Things I’ve tried:
-set idle=nomwait processor.max_cstate=5 in the kernel command lines
-disable lower current when idle in BIOS

specs:
CPU: Ryzen 5 3500X
motherboard: Gigabyte B450M DS3H Wifi, BIOS version F62
GPU: Sapphire compact (Radeon R9 285/380)
memory: 2x8GB Crucial standard-ass DDR4 sticks, clocked at 2666 MHz
OS: Arch linux, linux-zen 5.18, linux-hardened doesn’t fare much better.

Most of the settings are totally standard, I don’t overclock anything.

What is your PSU?

Also is your PC plugged in the same electrical line as refrigirator, microwave and similar eletronics that can suddenly pull a lot of power from the wall? If so, do you have a UPS/know someone that can lend you one?

3 Likes

I second PSU. What PSU you running?

2 Likes

go into uefi and look for high precision event timer…
enable it.
its off by default on gigabyte boards.

its a hardware clock that needs to be on for most of todays hardware configs.
regardless of windows or linux.
(turns out debian needs it or suffers random crashes and lockups, just like windows 7/10/11)

so yeah check to see if its disabled. if it is, enable it…

(especially if you have amd based gpu’s)

3 Likes

It’s a pretty old PSU, Rosewill brand. I manually checked all the output voltages when my old motherboard died, they were stable at about 0.1-0.2V above nominal. Is that a problem? The wiring in my apartment isn’t great but at least in my apartment nothing big is on the same circuit. I don’t know where I could get a UPS.

enable high precision event timer

it was already on, I must have turned it on when I went through to enable IOMMU and virtualization.

1 Like

When some capacitors in old PSUs die, they dont fail catastrophically (sudden off, or in worse cases, bursts and may start a fire), they just stop storing their charge which can cause lots of diffent kinds of issues.

3 Likes

I’ll try getting a new PSU.

what bios version you on?.
maybe theres a stability update…
but saying that gigabytes update process is a pain in the ass and if you get it wrong you will brick the board. i would say its up to you if you want to risk it.

that being said, the cpu came from a build that had already failed due to bad power on the motherboard.
its entirely possible the cpu is now flaky because of it…
so if you can try that cpu in another build and test it for stability in a system you know works.(maybe a mate or fam member if you dont have one spare?)

2 Likes

:warning: Don’t do this. The purpose of an anti-static bag is to dissipate any charge building on its outer surface by conducting it to another surface it’s touching. It’s not an insulator, so not at all suitable for putting directly in contact with powered electronics.

2 Likes