Return to Level1Techs.com

Unigine Superposition won't run on Kubuntu 18.04

Looks like the new QT framework that Kubuntu comes with is incompatible with Superposition running on Kubuntu 18.04. It is currently impossible to run Unigine Superposition on Kubuntu 18.04 due to QT5 framework differences. Anyone else had any better luck with this?

Never really tried to do anything about it since the AUR version wouldn’t finish install on manjaro KDE.
Valley workes fine though… and so did Heaven.
And Valley also works on Kubuntu 18.04.
Weird.

Yup, just confirmed Valley works on 18.04. This bug with Superposition is QT5 framework specific.

Maybe we should petition them to make a Snap package?

Months later, and still, with the QT5 framework from KDE installed, even on 18.04.1, Superposition won’t run. Apparently this is the only thread on this issue on Kubuntu, but as noenken said, Manjaro with KDE installed also has similar issues:

Vanilla 18.04 works fine according to others posting threads running vanilla 18.04: (after resolution scaling is dealt with)

Ubuntu 18.04.1 is the latest LTS release so you figured they’d release a 1.01 bugfix for Kubuntu, but nope. This bug is Kubuntu specific, so no one is bothering.

Edit: I may have a fix… Stay tuned.

SOLUTION:

1 Like