Unable to use Both Nvidia & Intel Together

I hope I am missing something basic here, but for the life of me I can’t get my displays to work with Nvidia and the Intel graphics. I did a fresh install. Out of the box Gnome saw all of my monitors across Intel using Nouveau and Nvidia GPU. Great! But I don’t have Nvidia drivers installed yet. However i3wm didn’t see my monitors plugged into Intel’s onboard video. I installed Nvidia drivers and disabled Nouveau because that’s a requirement for Nvidia drivers now. :frowning: Of course, I lost my monitors plugged into the iGPU. arandr --ListProviders, Gnome’s Display Manager, and Nvidia doesn’t see the monitors plugged into the onboard video. All research points to using Nouveau with Nvidia, but Nouveau doesn’t play nicely with Nivida anymore. iGPU is still enabled within the BIOs. I should also note, there are multiple grayed out entries within arandr. DP-0,DP-1,DP-3,DP-5, and USB-C-0. Those ports would make a lot of sense as I am currently using a Thunderbolt 3 port. Also, all of my monitors plugged into Intel onboard ports are displaying a black image with the backlight, but they are still undetectable. So except for that, I’m not sure where to go from here.

Fedora 32 i3wm, Nvidia 450.66 10900k, 2080 Super, Gigabyte z490 Vision D

lspci|grep -i VGA && xrandr --listproviders && xorg.conf https://pastebin.pl/view/b9b059f9

Nvidia Drivers:
Install kernel-devel kernel-headers gcc make dkms acpid libglvnd-glx libglvnd-opengl libglvnd-devel pkgconfig, blacklist nouveau, within grub blacklist=nouveau, update grub2, remove nouveau, generate initramfs, and install nvidia drivers.

1 Like

Nouveau does not work well on the 1xxx GPUs and newer.

You need to look at seting up Prime, Optimus, or Bumble Bee.

While I am running Ubuntu Focal, not Fedora, I didn’t need to remove or blacklist anything for the NVIDIA drivers to work, including Nouveau, I just installed the driver package and was ready to go. NVIDIA Prime (prime-select; NVIDIA’s documentation, including how to use the on-demand profile) comes with recent versions of the NVIDIA drivers, so you don’t need to install a separate programme, like Bumblebee (I tried using it before I learned of prime-select, but it was a horrible experience). It has three profiles which you can choose from (Edit: the reason why nothing other than the profiles is visible is because I’m in Intel mode and in the Wayland session):

Did you try simply installing the driver package from the repositories? If you had tried installing it and had issues, could you elaborate upon them?

Also, I do not see any details regarding the aforementioned Intel iGPU in the terminal output which you have posted externally (on Pastebin as opposed to in a collapsible paragraph in the post, assuming that this forum supports that), it’s not even listed as one of the providers by xrandr from what I can tell. You mentioned that GNOME can detect all of the displays before installing the NVIDIA drivers. How does the situation change with them installed? How does i3 behave without the drivers installed?

Regarding Nouveau, it is as Mastic_Warrior said, it does not work with recent NVIDIA GPUs, including my MX230.

1 Like

When you grep for VGA, does it only return with your Nvidia hardware or does it include your Intel graphics as well? [lspci|grep VGA] It should return with both, right? I’m not sure if my problem is linked to how my hardware is being seen or another factor, but it should be linked to the missing Intel graphics. Do you know if your system was always able to see your Intel graphics?

I read into Prime, Optimus, and Bumblebee, and I think I understand the basics of it. I like the idea of offloading and selective rendering with those solutions. Will this help me multiple monitors though?

Regarding Nvidia installation, there is also akmod-nvidia, but I wasn’t able to find the repo with dnf install akmod-nvidia for the last month. It would return with unable to locate the package. https://rpmfusion.org/Howto/NVIDIA

ListProviders should return with one line for Intel and one line for Nvidia, but as posted in Pastebin, that’s not happening after installing Nivida drivers.

Gnome’s Display Manager is unable to see my monitors plugged into the onboard video ports after the installation of Nvidia/removing Nouveau. Before and after the installation of Nvidia, i3 wasn’t able to see the iGPU’s monitors. However Gnome was only able to see them before the installation.

Well… This is how they’re detected on my laptop:

[email protected]:~$ lspci | grep --ignore-case "3d\|vga"
00:02.0 VGA compatible controller: Intel Corporation Device 8a56 (rev 07)
01:00.0 3D controller: NVIDIA Corporation GP108M [GeForce MX230] (rev a1)

I’ve never had any issues detecting either GPU, even before installing any additional drivers (I can’t run xrandr as I am in a Wayland session and all). Regarding that, maybe the manual driver installation messes something up? I’m not sure.


After digging around for a bit with the official web site as my starting point, I deduced that there have been no new commits in the main Bumblebee repository since 2013, the latest sign of activity being the FAQ being last edited in 2016. Unless there is something that I have yet to find, Bumblebee is quite old and seemingly dead, which would explain my horrible experience with it in the past (your mileage may vary though).

Regarding Optimus, I’m not sure whether you’re referring to the technology or some specific piece of software, so I’ll just link to this: https://wiki.debian.org/NVIDIA%20Optimus

Hm… Until somebody with actual experience with Fedora repositories comes along, all that I can say is to tripple-check every step of the process, including adding the repository.

I think that there are two ways that you could go about this once you get i3 to detect the monitors with just the iGPU (or you could just switch to GNOME), you could run everything on the NVIDIA graphics card with the performance profile, making the iGPU dead weight, or you could use the on-demand profile and manually run programmes from the terminal with the two environment variables mentioned in the documentation in my previous reply whenever you wish to utilise the graphics card, thus using at least a bit less electrical power and not having the iGPU as dead weight (I know that GNOME has that “Launch with dedicated graphics card” option in its right-click menu when you right-click on an application icon, but that only sets DRI_PRIME=1, which is not helpful in this case).

Anyways, as it is getting fairly late here in Sarajevo, Bosnia and Herzegovina, I have to bid you farewell for now. Have a nice day!

I had issues installing it on my desktop 2070.

This was the guide I used to install the propietary drivers

I got it working documented here,