Unable to bind nvidia GPU to vfio-pci on CentOS

I’m trying to get passthrough working on CentOS.

The VFIO driver is successfully binding to the audio device, but not the GTX 1050 Ti that I have.

I just tried to add the file /etc/modprobe.d/nouveau.conf and put softdep nouveau pre: vfio vfio_pci in it, but now my system is hanging at boot with Started GNOME display manager.

I might just reinstall quickly to get the system working again so I can play with it, but whats the correct way to deal with vfio not binding to the GPU in CentOS?

I also have a GT710 for the host, so i need to be able to use that.

How’s this going?

Did you manage to solve it yet or are you still at the same point?

do you have a second system (or phone) you can use to SSH in and check if it’s binding things properly?

Is there a reason you’re using CentOS? I’ve had better luck with Fedora, which is just a bit more up-to-date and desktop oriented.

Hi there! Sorry for the slot reply, I’ve been forced to fall back into Ubuntu temporarily because my GF needs to do some college work and i’d rather not mess around with it until her exams are over next week.

I must admit I was actually a bit clueless when I wrote this post because I had an issue where I’d try to follow a guide but sometimes it just wouldn’t work. Then I tried changing random settings and sometimes it would work and other times VFIO would lose the binding after a reboot.

But after doing some deeper reading for the last few days, trying to understand the direct equivalences between the two systems, I think I may have figured it out.

@SgtAwesomesauce I’m looking to switch to CentOS because I’d like to run DaVinci Resolve natively, which only officially supports CentOS. I’ve seen videos of hacks to get it to work in Ubuntu, but I’d rather not.

I have also confirmed that the system does in fact boot in the background even though it appears to hang at boot.

My question is, does this happen with some distros? I just want to know if this is a common problem or simply a result of my failed configuration.

@Goalkeeper I’ll be reattempting this in a few days, but I’d like to confirm a few things.

1 Like

I’ve wrote myself a cheatsheet for passthrough in Mint/Ubuntu

Ive been following this guide for CentOS

I get confused because of the differences in commands between the two systems.

In my own cheatsheet, I have to add/modify files in the following locations:

What are the equivalent locations/files for CentOS?
It it like this? left side is ubuntu = right side is CentOS

/etc/modules = /etc/modules-load.d/xxxx.conf (kernel modules to load)
/etc/modprobe.d/xxxx.conf = /etc/modprobe.d/xxxx.conf (same)

But then what is /etc/initramfs-tools/modules (ubuntu) equal to in CentOS?