Return to Level1Techs.com

Ubuntu 16.04 Hanging on reboot

Hi

I'm having a bit of an issue with a new install of Ubuntu 16.04 on a HP Elitebook 2560p Laptop where upon reboot the system seems to hang on the Bios Splash screen. I say seems to because you can't actually select any options or anything. All you can do is switch the system off with the power key.

Normal shutdown and power on works fine.

The laptop previously had Windows 7 Pro on it which worked fine though that was on a HDD. I have since put in an SSD and installed Ubuntu.

I've tried adding a reboot= option to etc/default/grub and doing update-grub but none of the different options seemed to help.

I'm sure i had a similar issue with Fedora 23 on another laptop but i can't remember for the life of me what i did to fix it.

Ubuntu was installed in Legacy Boot mode as UEFI boot was disabled. I'm not opposed to reinstalling Ubuntu in UEFI mode if that will fix things but would rather not if I don't have to.

Any help or suggestions appreciated.

EDIT: OK so I think I've at least found a fix of sorts.

1) First I ran Boot-Repair on this machine. Since Ubuntu booted fine as long as it was a cold boot after being shutdown I was able to install it direct using the following:

sudo add-apt-repository ppa:yannubuntu/boot-repair
sudo apt-get update
sudo apt-get install -y boot-repair

Then running Boot-Repair by just typing the following in the terminal.

Boot-Repair

Then followed the prompts for a Recommended Repair which basically uninstalls and reinstalls Grub. WARNING DO NOT ABORT ONCE STARTED. Part way through the repair it uninstalls Grub and if you don't let it finish you won't be able to boot your OS at all anymore. The only way around this I know of is to use a Live CD to run Boot-Repair instead and boot of that.

Now this didn't immediately fix the reboot issue, but it did fix something I didn't even note was a fault which was Grub was actually loading. I mean it booted into Ubuntu fine and since it was an SSD I just assumed it was quick and didn't notice until after the repair I wasn't getting the Grub Boot Options which I now am.

The only reason I'm even mentioning the Boot-Repair is because this next step didn't work the first time I tried it before I ran Boot-Repair.

2) So Step 2 I went back into /etc/default/grub and changed the following:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

To:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash reboot=warm,cold,bios,smp,triple,kbd,acpi,efi,pci,force"

Basically I added all the Reboot parameters to this part and I then ran the following:

sudo update-grub

And rebooted. Now the system appears to be rebooting fine. I'd previously tried the above to try and work out if the Reboot parameter would fix this but it didn't help previously although that was before I tried a boot-repair so its possible the reboot parameters weren't actually being passed I suppose if Grub was broken.

Interestingly I've tried each reboot parameter individually to try and work out which one fixes but it only seems to work when I do all of them (I admit I've not tried all the combinations). I'm not sure why this fixes it but it does.

Anyone got any ideas why using all reboot parameters fixes but individual ones don't out of curiosity?

And will the above cause any issues rebooting in this way?

Otherwise I'll just run the system like this from now on cause if it works then that's good enough for me :-)

1 Like

switching my laptop to fedora fixed so many boot issues I was having on Ubuntu 16.04