Ubiquiti gear, what should have been a simple task

I’m not a complete network rookie, but the certificate I have to prove that, I took nearly 10 years ago.

So, a buddy of mine wanted help improving the networking situation at a local resturant/concerthall, (no idea what it is, they play music and serve food, occasionally standup and maybe an odd lecture, but also have live concerts). He had already tried himself, and he’d gotten another local guy to try. Both of whom failed.

I figured I could do it.
I could not.

It’s a private network that never needs to connect to the internet.
They have two pieces of audio gear that needs fixed IP addresses, and they must connect to the router with cable. Then they want an accespoint for a handful of tablets and phones for staff/technicians. Everything has to be on the same subnet.

I was given two pieces of gear to work with.
1 EdgeRouter PoE router to work as, I guess switch?
1 NanoStation M5 to use as wireless accespoint.

I’m aware that the above are odd choices for gear, but I had no hand in picking them out. I’ve just been tasked with getting them to work.

I’ve been poking at it for a few hours but ended up getting frustrated. The web interface straight up crashed and I’ve been unable to re-log onto the Router, seemingly for no reason. And logging back in required a reset of the device, making any changes a wasted effort. Partly I suspect bad cable or something. Also the Router gets hots, not too hot to touch, but close.

What I tried/how far I got.

I enabeled PoE on eth4 to power the NanoStation, that works fine.
I enabeled the Router to be a DHCP server, to hand out some IP’s. I assume it works but I can’t really test it.
I switched ports 2, 3 and 4 because I don’t think I need it to route between the same subnet, right? I want 2 and 3 to be the audio gear.

I’ve also, sort of, setup the NanoStation as accespoint.
Wireless is set to be an accespoint.
SSID is hidden, WPA 2/PSK, and I think AES encryption. However when I attempt to connect to it, wirelessly, I’m getting a security error. Not sure why, both my phone and win7 laptop wont connect to it.

For Lan settings I set it to be a bridge, not sure this is correct.

I know there must be setting I’ve gotten wrong, probably something simple. Any advice will be much appreciated. Step by step guide would be helpful, but I suspect I’d learn more from crashcourses on what I need to know.

I’ll be happy to elaborate and clarify, but for now I want to look at something tha isn’t the webinterface.

Thanks in advance.

PS, I’m not really in a hurry as I’ve borrowed the router and the accespoint until I can sort it out.

You don’t specifically mention if you are using the Unifi Controller, which is, IMHO, the easiest way to configure and manage Ubiquiti access points. The controller only needs to run for configuration and firmware updates, otherwise it need not run.

The Edge router is more conventionally configured via its built-in GUI, but there is a handy terminal available also, which Ben Pin uses to good effect in his vids.

A couple of YouTube sites, in particular, have good step-by-step vids on setting up the Unifi controller, Edge routers and Ubiquiti access points (I’m sure there must be others):
Ben Pin
Crosstalk Solutions
Willie Howe
Lawrence Systems

Best of luck!

You don’t need to worry about the Unifi Controller that is just for their Unifi line of products. The Edge Router and the NanoStation are managed either through their respective web interfaces, console, or the optional UNMS Controller.

Some NanoStations units come with wifi modes that are proprietary (AirMax or AirMax AC). These improve throughput and reliability when all devices support it but break compatibility with standard devices. Make sure that you turn those off. I ran into the same issue when I tried to use a NanoStation as an temporary AP once.

If that does not fix it I would try making the WiFi a simple unsecured open network first, then enable your final settings one at a time, testing the connection each time.

I’m not using the unifi controller. I was doing everything through the web interfaces.

No doubt there must have been improvements over the last few years, but I found both the web interface and the phone app (for the access points) to be an exercise in frustration. While not technically necessary, IMHO using the Controller is dead simple and the best way to go. Ubiquiti have a Controller manual on their site, which provides rather exhaustive coverage of the Controller’s features.

Obviously, with the Edge router, you’re stuck with the web interface, but this isn’t an entirely bad thing.

One other thing to keep in mind is that Ubiquiti manufacture their POE components to various (AKA non-interchangeable) standards. So, you’'ll always need to ensure voltage compatibility, unless using their respective power injectors.

You mention using both a NanoStation and an Edge router, both of which are … routers. While the EdgerouterX can definitely be configured as a switch, I’m not so sure that the Edge router possesses this flexibility, although you can bridge the ports. Also, I’ve deployed the NanoStation to good effect and IIRC, the routing functionality can be disabled, if desired.

Crosstalk Solutions have particularly good vids on setting up a basic network with all of this equipment. Once you have that running, adding your custom requirements should be rather straightforward.

Thanks, I’ll look at the crosstalk solutions after sleeping.

I got everything - kind of working -.

Was able to log both laptop and android phone to the Nanostation and the DHCP server actually worked, assigning 3 ips, 2 for wireless and 1 for the wired connection to the nanostation/accespoint.

From the laptop I could connect to, and control, both Edgerouter and nanostation wirelessly. However phone couldn’t ping anything, laptop could only ping router/accespoint.

I’m also beginning to think there’s some heat issues, maybe?

Everything seems to work less / be more buggy as I tinkered with it. I suspect the 48 volt powerbrick for the Edgerouter is overkill. But according to the sticker that should be the very upper limit the edge router will accept (also what came with the device, apparently). Adding the conversion down to 24V for PoE to the nanostation, might be pushing things a little too far. I assume it’s simply using resistance to bring the output voltage down to 24V.

When I had everything - sort of - working, I saved the config files to my laptop. Just a kind gesture to future, equally sleep deprived me.