Two Intel NICs and neither are recognized

I’ve bought two different intel Pro/1000 NICs, and no matter what I’ve tried I can’t get them to show up. The BIOS doesn’t see them, and Linux lspci doesn’t either. They are pic-e x4 cards.

I’ve tried changing the slots, I’ve poked around in the BIOS to see if there was some setting I could toggle. For the proxmox machine, I updated the BIOS and nothing.

If anyone has any experience with these cards or can offer any advice it would be greatly appreciated. My goal was to virtualize PfSense with these.

The systems I’ve tried on is:

  • Ryzen 5 5600g + Asus ROG b550
    • OS: arch linux
  • Ryzen 3700 + Gigabyte Aorus Pro b550-m
    • OS: proxmox
  • i7-4790k + Asus Z97-A USB 3.1
    • OS: none, tried a few different distros from a live USB including arch and fedora

The cards are:

  1. HP 2 port nic

  1. Intel Pro/1000 PT Quad Port

Shouldn’t need to do anything special, they should show up as Intel 82571EB Dual/Quad in lspci, and load the e1000e module.

Any signs of damage? I can’t quite tell by the picture, but the PCIe pins on the HP one, just left of “MALAYSIA” on the sticker looks dodgy.

Are these brand new? Where did you buy them?

They aren’t new, they’re used. The HP one I saw working before I purchased it.

One thing I’ve read into is that these cards are pcie 1.0a and thus too old to actually work on my newer platforms (even the i7-4790k).