Return to Level1Techs.com

TV connected to PC lags while playing video when I turn main monitor off

I got a very weird problem.
My computer is setup like this:

My graphic card is connected to - Main monitor (4K) through DisplayPort, secondary display (1080) through HDMI.

TV (1080) through HDMI to onbard intel graphic card (cause gfx card has no more hdmi ports)

Now, as long as the main monitor is on, everything is smooth on the TV.
But if i turn it off, it will play at like 15fps and be unwatchable.

I tried everything i could think of. I even connected TV to nvidia card, and the issue persisted.

EDIT: I just realized this only happens when playing video through through Chrome!
I do have hardware acceleration on.
So maybe once the main monitor is turned off, it has problems using the gfx card to play video?

OS, GPU Drivers Display settings (resolution, refresh rate)?

Probably not this but just in case, double check power settings in windows. Maybe it for some reason sets it to powersaving and low performance.

Right click desktop, display settings, advanced display settings, check refresh rate

1 Like

I have two monitors and have a similar problem, but on a single card.
What you can try is switching the output to “second screen only”, WIN_KEY+P and selecting “Second screen only” to see if it works like that. You can turn off the monitor after switching the output.

Also, try and make the TV your main display, there is some checkbox in display settings and see if that helps. It’s a pain in the ass as your start menu will be on the TV but at least you can narrow down the issue.

I have been messing around with refresh rate since I thought this might be the cause.
When it’s set to the “proper” refresh rate (60i Hz) it has the low framerate issue.
If I set it lower (30p) it plays somewhat smoother, but the picture quality is horrible.
When the main monitor is active, the refresh is at 60i Hz.

another weird issue with the intel graphic card control panel application:
It shows that the TV resolution is set to 4k (which it is not) and when I try to change it to 1920x1080 and hit apply, it goes back to show 4k.
while in the windows settings it shows 1080:

But I assume it might just be a bug with the application.
I do have the latest drivers.

I tried your suggestion, unfortunately it didn’t have any affect.
Even when the TV was set as the main monitor.

I wonder if the intel graphics is taking the nVidia settings as the set defaults. You said your main monitor is 4k right and plugged into the nVidia card? Can you set that one to 1080p and just see what happens?

I just realized this only happens when playing video through through Chrome!
I do have hardware acceleration on.
So maybe once the main monitor is turned off, it has problems using the gfx card to play video?

I tried watching netflix through Edge and it worked just fine.
Now I’m unsure what happened to Chrome.

1 Like

Sounds like a good idea, give it a bash.

Turning off hardware acceleration did fix the issue.
Except… now all of chrome is slow when browsing some websites.

I wonder if there is a better way to tackle this.

Can you swap you second monitors HDMI cable to the Intel output and your TV to the nVidia HDMI output.

That way when you turn the main monitors off the TV is still running off the GPU and can do the hardware acceleration.

You know what… I guess that would work.

But There’s only one thing I’m scratching my head about:

Why can’t I choose 60i Hz in the Nvidia control panel :thinking:

can you choose the 1080p option above that one?

Yes, but even at 60Hz the picture quality of 1080p is horrible.

Can you try some lower resolutions, TVs are often weird and say 1080p but are actually something else.

Like in those options they are all 1080p and 1080i but the actual resolutions next to them are no 1080 anything.

Actually, it was the opposite!
The native resolution for the TV is 4K as well.
So I’ve set it to that.

Now I just hope that running 2 displays at 4k and one at 1080 at the same time won’t destroy my graphic card :joy:

Anyway, Thanks for all the help!

As long as it is not having to push 3D stuff on all of them should be fine, regular 2D desktop stuff is easy, the GPU will not even get above idle.