Turning of the Onscreen Keyboard

I'm running Windows 8.1 on my laptop which has a touch screen.

Sometimes I accidentally tap on the screen and hit a text box instead of what I meant to click. This brings up the onscreen keyboard. The issue is every time it comes up it screws with my desktop and moves the icons around. 

Anyway to stop the onscreen keyboard from automatically coming up?

Disable The Touchscreen Keyboard

It's somewhere in the middle of the side.