Return to Level1Techs.com

Trying to install office 365 in pop, but wine/POL is a hurdle

Hi everyone, I’m a long time fan of wanting to migrate to Linux, but I haven’t had the chance to do it as most of my professional work has been done in WIndows. I have at various points been using ubuntu and mint, but largely distro hopping and found ubuntu back in 2013 disappointing/incompatible with my life. Now with more robust OSes, I want to make a full time commitment.

I’ve repurposed an old PC to give myself a proper challenge to fully immerse into Linux. I chose pop_os understanding that the driver compatibility and ease of use.

As I have been getting myself more familiar with ubunut/linux, I have bent on trying to get office 365 installed. I have searched the web, and I am under the impression that in 2019, getting office 365 to work is possible:

I have based my approached relying on this thread:
https://appdb.winehq.org/objectManager.php?sClass=version&iId=35527
Someone one reddit has shown this is possible:

As a nooob, I kindly ask for some guidance. I’m trying to:

  1. get the wine 4.1.x version. I’m still on 4.0.2.1
  2. which comment in the wine link I should folllow and how do I add the various commands in the terminal?

Thanks

On trying to the wine 4.1.x:
I have been following this guide:
http://ubuntuhandbook.org/index.php/2019/09/wine-4-16-released-install-ubuntu-19-04/, and have run into issues

sudo apt-add-repository ‘deb https://dl.winehq.org/wine-builds/ubuntu/ disco main’
Ign:1 http://dl.google.com/linux/chrome/deb stable InRelease
Hit:2 https://dl.winehq.org/wine-builds/ubuntu eoan InRelease
Hit:3 https://dl.winehq.org/wine-builds/ubuntu disco InRelease
Hit:4 https://dl.winehq.org/wine-builds/ubuntu cosmic InRelease
Ign:5 https://dl.winehq.org/wine-builds/ubuntu Pop!_OS InRelease
Ign:6 https://dl.winehq.org/wine-builds/ubuntu Ubuntu InRelease
Err:7 https://dl.winehq.org/wine-builds/ubuntu Pop!_OS Release
404 Not Found [IP: 151.101.78.217 443]
Err:8 https://dl.winehq.org/wine-builds/ubuntu Ubuntu Release
404 Not Found [IP: 151.101.78.217 443]
Hit:9 http://dl.google.com/linux/chrome/deb stable Release
Hit:11 http://apt.pop-os.org/proprietary eoan InRelease
Hit:12 http://us.archive.ubuntu.com/ubuntu eoan InRelease
Hit:13 http://ppa.launchpad.net/cybermax-dexter/sdl2-backport/ubuntu eoan InRelease
Get:14 http://us.archive.ubuntu.com/ubuntu eoan-security InRelease [97.5 kB]
Hit:15 http://ppa.launchpad.net/system76/pop/ubuntu eoan InRelease
Ign:16 http://ppa.launchpad.net/wine/wine-builds/ubuntu eoan InRelease
Err:17 http://ppa.launchpad.net/wine/wine-builds/ubuntu eoan Release
404 Not Found [IP: 91.189.95.83 80]
Get:18 http://us.archive.ubuntu.com/ubuntu eoan-updates InRelease [97.5 kB]
Get:19 http://us.archive.ubuntu.com/ubuntu eoan-backports InRelease [88.8 kB]
Reading package lists… Done
E: The repository ‘https://dl.winehq.org/wine-builds/ubuntu Pop!_OS Release’ does not have a Release file.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository ‘https://dl.winehq.org/wine-builds/ubuntu Ubuntu Release’ does not have a Release file.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository ‘http://ppa.launchpad.net/wine/wine-builds/ubuntu eoan Release’ does not have a Release file.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Are you using popos 19.10? If so maybe it would work with

sudo apt-add-repository ‘deb https://dl.winehq.org/wine-builds/ubuntu/ eoan main’

PopOS 19.10 is based off of Ubuntu 19.10 which is called Eoan Ermine

I generally setup containers and configurations in Lutris since it has some decent runners you can pick from.

In saying that Lutris has a learning curve, just like wine, it’s all a learning curve.

nope…

getting thls:
Error: need a single repository as argument

Even for Office?!
Is there a good material you can kindly point me to? Thank you

If I come across something I’ll let you know.

This guy recommends getting codeweavers thing: