Truenas Permissions And File Duplication Problem

Hi There

I will start off by saying i am very new to Freenas/Truenas so if I get something wrong I’m sorry I’m still working my way around it.
I am running Truenas Core 12.0-RC1 on 4 WD Red Pro 10TB in a RAID 0, before anyone says I should do that I no I am for the moment while I get used to Freenas/Truenas
I have a backup on a different server relax I no. I need to get more drives to expand it properly and I will do a better setup once I have them.
I am using Windows 10 Pro computer and connecting to the Truenas machine over SMB.
I have only 2 accounts the root and my account, I use the storage for photos and video for work.

Now my problem I could have set it up some how that’s wrong I don’t know but I keep getting the same problem with folders and files being locked unable to rename, open, move or look at the properties for the files in windows. The way I have being fixing the problem is by going into the Users/Username/Edit/ then selecting the folder and saving the permissions for each folder that has a blue ACL box next to the folder name in Directories and Permissions. This is annoying as you can guess if I have multiple folders that I need to do this with.
so that’s the first part of the problem the second is after I went and fixed the ACL on the 7 folders I have to before posting this I looked in one of the folders and found files from some of the other folders having the same ACL problem had ended up in the wrong folder. Some might think i just moved the videos and photos into the wrong folder but it made copy’s of the files and only put some random ones in there.
For example one folder (lets call Project A) had the correct 125 video clips for that project in it but also had copy’s from a different folder from a different project (lets call project B) in it and the project B folder had videos from project A but also had photos from a different project again.

I will now have to look over all my folders to make sure the correct files are in the correct folders for every project I have on this Truenas machine before i send the footage to my clients.

Dose anyone know why this is happening and how to make sure it doesn’t happen again?
Just an update I posted the same info on the Truenas form yesterday afternoon and today when sorting out files and folders again today i had the same problems happen all over again making it twice in 2 days this has happened.

Any help/info Would be great, Thanks

1 Like

Sounds like you have permission issues with your user. Also, since you are using a release candidate (RC1), you should expect problems still even though version 12.0 is almost ready. It’s as if your files were being thrown around at random which is quite peculiar indeed.

If you copied your files over from a different user, then that is expected behaviour. There definitely are so many ways to set up your server that it is difficult to help you out without knowing more. Make sure you read again how to set up your Windows users in the extensive documentation. There just is no other way I’m affraid. But once you learn it, you won’t forget.

My suggestion is you either install the latest version 11 instead or, it looks like the first stable release 12.0-RELEASE is now available, so upgrade to it if you can. Better yet, redo the install completely and make sure you set up everything again and understand it well. It’s worth it because you are learning and doing it a second time will help taking it in and understanding. I messed up my first couple of installs too, and appreciated doing it again while testing with data I could afford to lose before going live.

Also, now you should set up your drives with a better Z-Raid and choose carefully because your choice will affect your server for a very long time unless you want to reinstall everything again. Adding drives in the future and how you do it will depend on how you set up your first Z-Raid. It’s important you understand that too. Maybe you know already, I just don’t know what you know.

You just won’t be able to change your ZRaid-0 without it being a headache or erasing your drives and making your server work very hard, at least I think.

I just remembered Windows doesn’t support SMB out of the box anymore, so you added Samba to Windows then?

I think FreeNAS is great, you made a great choice. Have fun!

1 Like

When old CIFS client is disbled windows just throws error, and you can’t connect at all. At least in my experience.

1 Like

What? No, it still supports SMB. Windows actually has had better support than Samba for advanced things like SMB multichannel (I think they are on par at the moment though).

You are probably thinking of SMBv1, which is disabled out of the box on Windows 10, but can be re-enabled in features. But that is for good reason, SMBv1 has terrible performance and security compared to v2 and v3.

Huh, I didn’t know that Samba had a windows port? Do you have a link?

Ah, no, I was just supposing you had to install it on Windows. I have a Seagate Home Somethingamajig 1TB drive I used to connect to with Windows and haven’t been able to connect to, but didn’t bother to fix it up for Windows since I mainly use Linux Mint.

You can enable CIFS 1.0 client in old “Add/remove features” on Win10. You have to run old “Programs and Somethings” widget for that.

Make sure the user you created on the TrueNAS box is the same name as the User on your windows box.
Make sure that they have the same passwords.
Go into your storage section, and go to the pool.
Edit the permissions of the pool/dataset that you want the user to have access to.
Make your user the owner and set the group to the user generated group.
Make the permissions read write execute for your user and group.
Make sure to check Apply User, Apply Group, Apply Permissions recursively, and Traverse.
Then Save the permission settings.

I have tried everything you guys have said short of reinstalling the OS and starting again, and I’m still having the same problems. I am wasting way to much time dealing with these problems I think I will just go back to windows server even though I would rather not.


1 Like

As I see you need All the types of permissions to be copied and applied on the destination, have you tried to copy via tools like Carbonite, GoodSync or Gs Richcopy 360?
These tools can keep all the folders permissions so, you you can work with it like the source folder,
Just try the trial version first

1 Like