Trouble with the GA-970A-DS3P motherboard!

Hi guys, I have been dipping my toes in the Linux ocean for a while now, and even though its cold I'm ready to fully dive in.
I was working on installing OpenSuse 13.2 on my main Workstation Rig.

Mobo: GA-970A-DS3P

CPU: FX8320

GPU: Radeon 7790HD

I am Having strange issues with my on-board Ethernet not being able to connect.

After doing some research I found that you want to Enable IOMMU

The Gigabyte GA-970A-DS3P is a ATX mainboard with AM3+ socket. The board is supported under Linux, but some additional settings are necessary to use it:

By default, the board is shipped with IOMMU deactivated in the BIOS. With such settings the USB 3.0 ports work under Linux, but the USB 2.0 and Ethernet are deactivated. If IOMMU is activated, USB 2.0 and Ethernet work under Linux, but the USB 3.0 ports are deactivated.

To use all three components in parallel under Linux, the IOMMU needs to be deactivated in the BIOS and the following “grub” configuration has to be added to the file /etc/default/grub:

File /etc/default/grub


The new configuration is activated by the command

sudo update-grub

When I ran the sudo update-grub command and I would give me a unrecognized command.

I am a windows power user and ran Ubuntu on a laptop for 6 months so I know basic stuff about linux but please be gentle X D.

Any Ideas would be great as I am hitting a wall.

I think I may try this BIOS setting called 60/64 Port Emulation, and may mess with the Legacy Setting.

The board is not certified for that CPU.

The maximum that board can handle, is an FX8300.

I've not heard of that "issue" with IOMMU on that board. The mobo feature implementation of AMD chipsets has to be followed by OEM's, so I don't see how this would not be addressed by a BIOS patch to be honest if such problem would exist.

grub-update was left behind years ago in RPM-distros. You should use Yast to update grub. It's entirely done through GUI.

Very strange with the Board not being certified for FX8320, Bios recognizes the CPU and it is working properly.

I may just be lucky and got two that happen to work together but may not be a 100% thing.

I plan on getting a ASUS MA599FX. I think that will work out better for me in the long run.

I had this exact same problem when I tried ubuntu and changing the IOMMU in the actual bios settings and it worked fine. 

I like to use Grub Customizer for editing my grub configuration. It's super easy to use and forgoes any of the manual commands etc.

It updates at save, so it may fix your update-grub command issue.