Return to Level1Techs.com

Trouble with Epic Games Store running through Wine

I am having trouble with getting the Epic Games Store running using the lutris script through Wine.

It starts up and lets me log in, but then the GUI becomes all garbled:

I am running Manjaro Gnome on Wayland
AMD RX 580 GPU

Has anyone encountered a similiar issue, and maybe know how to fix it?

Thanks in advance.

1 Like

Dont use wayland, even if you use AMD GPU. Wayland is not yet there for gaming. Try to use X

Wayland is the issue.

Wayland is not the issue. Already checked the obvious. And there are no issues using Wayland for gaming, that is simply not true anymore.

In fact Wayland is causing me less problems with gaming than X11 ever did, especially considering screen tearing. Switched to Wayland because of FPS issues caused by X11.

Things I already checked:
Problem persists in both X11 and Wayland.
Launcher is running in opengl which seems to be related to the problem, running using dxvk does not garble the GUI just makes the web components flash and basically unusable.
Disabling dxvk results in the same problem as forcing openGL.

I solved this myself. Didn’t realy change anything, but it has to do with the fact that the Epic Launcher creates a core 4.4 openGL context but uses deprecated functionality of openGL that requires compatability mode.

Basically, bad coding practices from epic. -_-

So what actually solved this was I eventyally was able to grab hold of the window edge and resized it, somehow that fixed the broken rendering.

2 Likes

Hmm, also be sure your container isn’t set to win7 or win8.1. Think I read someone that it demands win10!