Return to Level1Techs.com

Trouble installing Proxmox

Hi,

I am getting:
error file ‘/boot/grub/x86_64-efi/normal.mod’ not found

This results in me getting put in grub rescue mode. I have attempted to fix this in Linux mint live but I am still stuck. Any help would be appreciated.
I installed PVE 6.2-1 using Rufus and etcher with 2 different USB drives and I still get this error.

Thanks!

Maybe there was an issue downloading the iso

2 Likes

Proxmox’s official documentation suggests using dd to prepare the boot media. When using Rufus, dd mode needs to be used.

I also agree with nx2l, and would suggest comparing checksums of the install image after it’s been downloaded.

4 Likes

I would just like to add that I used Balena Etcher on MacOS and was able to install Promox without issue.

Etcher is available on Linux, Windows, and MacOS.

If you keep getting the error about boot media then try using a different flash drive.

I tried different usbs, redownloading the iso, using rufus (with dd) and using etcher. I am still getting this error.

try the pve6.1 iso… see if its boot able?

1 Like

I get the same error on 6.1

When you compare the sha hash does it match what is on proxmox website?

1 Like

Yes.
“SHA256 hash of .\proxmox-ve_6.2-1.iso:
d8fb3cfba19d38aa0c05452a954150f96e3ee455a36d52427aa26e6906fb8bff”

image

Do you have secure boot enabled or disabled in your UEFI?

2 Likes

I do not see the secure boot option in my bios. I have an r210 ii.

Hmm I found this link.

https://www.dell.com/community/PowerEdge-Hardware-General/Can-t-figure-out-how-to-boot-R210-II-from-USB/td-p/3832993

Apparently, in order to boot USB on this unit one must tell the system that the boot usb to emulate a hard disk and then it should work.

2 Likes

I am able to boot the installer and install proxmox to my HDD, but booting proxmox from the HDD leaves he with the normal.mod error.

I found a pretty extensive write up here

It’s pretty much exactly what you have but sub out the i386 bits with your x86_64-efi stuff.

1 Like

It did not work.

I swapped HDD and it works fine now.

1 Like