Trackpoint issue

I've tried searching high and low, and just can not seem to find a solution. Running the 5th Gen Thinkpad X1 Carbon, and xinput doesn't properly recognize the Trackpoint, instead registering it as "PS/2 Generic Mouse" instead of "TPPS/2 IBM TrackPoint".

The issue I'm having is that compared to using Windows, the Trackpoint requires a LOT of force to get moving. it will move quickly when pressed hard, but in Windows there was an option to adjust sensitivity so that it required little effort to move quickly. Now on the otherhand, the touchpad works great in Linux (though the palm detection is non-existent, or royally sucks).

I've tried editing xinput to the best of my ability, and after months of looking into this, I finally have to admit defeat. I broke out my old w520 that still rocks Windows, and WOW was it refreshing to use a Trackpoint with that sensitivity again! I REALLY would love to get it working like that in Linux, as it has been the ONLY sore-point in using Solus for me.

Someone please help!

Theres an xinput setting "Device Accel Constant Deceleration'
xorg info

basically where the trackpoint recenters itself like a joystick when you stop moving it the driver for it has to compensate for that, its set too high and is overcompensating.

Theres probably a graphical tool that can configure the setting you want without having to muck about in xorg.conf though.

as far as device detection/id goes, it may be worthwhile checking to see if all the xorg input drivers are installed

I've tried looking into that, but still stuck. Can't find that setting anywhere. I tried editing "libinput Accel Speed" to 0 with no change (it's a binary setting). Here is what I'm looking at:

EDIT: I should note that I came to the conclusion that it was device 13 by changing the "Device Enabled" value to 0, and it was the only one that disabled the Trackpoint.

Have you tried:
xinput --set-prop "<devicename>" "Device Acccel Constant Deceleration" 0.125 < this may also be of some use

it seems using udev instead of xinput seems to be the better/new method.

Still no luck. Doesn't recognize that command:

Tried something else as you can see, still no luck.