Too dumb to set up StarTech Dual M.2 SATA Adapter RAID1?


I’m currently a bit confused since I don’t get something basic done. I wanted a solution to have a RAID1 volume on a standard AHCI SATA HBA, independent from any OS support.

For testing I got two StarTech 25S22M2NGFFR adapters - they behave exactly the same so a random hardware defect seems unlikely.

The motherboard SATA HBA does not support port multiplying/PM (that shouldn’t matter since I only want to use RAID 1?)

What I tried:

  1. I install the two 960 GB SATA - not NVMe - SSDs (after a secure erase, so absolutely blank) without any issues on the 25S22M2NGFFR, set the switches to RAID 1 (ON - 1 - ON), connect only SATA power to the 25S22M2NGFFR (no SATA data cable to motherboard) and then press the “RAID set” button.

  2. The 2 error LEDs on the 25S22M2NGFFR are flashing and after a short while stop

  3. I disconnect power, set the switches to JBOD (ON - 1 - 1), since the manual states “Note: In order to configure your device to RAID 0 or RAID 1, your device must be configured to JBOD.”.

  4. After I reconnect power and the SATA data cable I can access a volume with the size of one SSD (as would be expected in RAID 1), however if I remove the 2 SSDs and check their data content directly attached to a motherboard M.2 SATA slot (independently, not at the same time), I can see that only one of the two SSDs actually contains data (Drive 1 slot of the device), the other one is still completely empty (no partition data at all).

Where did I do wrong?

Does this not just mean that you have to go from JBOD to RAID 0/1?

Setting back to JBOD after RAID 1 just puts it into JBOD mode again, meaning the adapter is only writing to the first drive.

Just do what you have been, but leave the switches in the RAID 1 setting.

1 Like

Unfortunately that doesn’t seem to be it (switches to ON - 1 - ON, press RAID set when connecting SATA power then and a power cycle and leave the switches as they are)):

The two error LEDs are blinking a bit and change to being permanently on then, no drive/volume is showing up when connecting the adapter to a system then.

Note: Before each try I erase the drives so there is no meta data left on them.

I would probably contact StarTech they probably have good customer support

Yeah, will do that and share the development here.

I also got the external USB 3.1 version of this product (SM22BU31C3R) and it works as intended: Set switches to RAID1, press RAID set when first connecting power and then you can just use it without changing anything regarding the switches.

Edit: Is anyone here knowledgable regarding the devices’ ASM chipsets and their bugs?

The USB 3.1 version uses ASM1352R, this SATA version the ASM1092R.

Or is there any other product where you can connect a RAID 1 volume to a simple AHCI SATA port? I also tried the S3520BU33ER with the older JMIcron JMS562 chipset is just extremely slow compared to the newer ASM ones.

1 Like

Stupid idea: Is there an active adapter to connect USB storage to a SATA HBA port? Quasi the reverse way of USB-to-SATA adapters that have become quite reliable with their newer generations.

StarTech’s support hasn’t responded to me, yet - but have tried a similar different product: 35SAT225S3R

I would have thought that this is basically technologically identical (but a different form factor for 2.5" SATA drives instead of M.2 SATA drives).

Here, you just set the switch to RAID1 and it works - maybe by chance I got two defective units of the initial StarTech 25S22M2NGFFR adapters, pretty weird.

This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.