Tomb Raider running too fast

I just downloaded Tomb Raider on my new gaming pc and it looks great except that it is running as if it were on fast forward. Has anyone had this problem before? I've played Tomb Raider on my laptop without any issues but it is running as if on fast forward on my new PC. I have the latest drivers installed so I don't think that's the issue.

System Specs:

  • CPU: AMD FX 8320
  • GPU: SAPPHIRE 100352-3L Radeon HD 7950
  • CPU Cooler: Corsair H100i
  • PSU: Corsair HX 750
  • RAM: G.Skill Ripjaws X 8gb (2x4gb) 2400mhz running at 1600mhz
  • SSD: Kingston SSDNow V300 Series SV300S37A/120G 2.5" 120GB

this could be caused by to many frames per second. try tuning on vsync. 

vsync was on by default. I also noticed that my other games are running faster than usual too. Yesterday, Saints Row IV was playing normally and today it felt like my player was moving much faster even when I wasn't using super powers. On Tomb Raider it also requires me to push buttons much faster to get through the quicktime events.

Wasnt that a problem with old pc ports?

try forcing 60hz mode. 

Right click the game and click properties. Go to launch options and put in -force 60hz


might be a different comamand. Google is your friend! 

Did you download any new drivers? If so roll back to the  old ones. Try deleting and reinstalling them. Other than that I can tell you if I have seen some weird real time clock errors. If it keeps happening you might want to look into that.

1. This maybe one of the reason. I think that there must have been a huge lag on the laptop that you were using, thus you feel everything in fast forward when at actual speed. Try watching a youtube video of the gameplay and check for he same.

2. I am having almost the same config, except different motherboard and different speed ram (why would you run a 2400Mhz RAM at 1600mhz ), I think the option of limiting the FPS can help.

3. Lastly update to latest AMD catalyst drivers, the new drivers are very good.

Very curious. I just going to state my curiousity here, I have no idea what could cause this.

It might be a "hardwareclock" screwing up, or not being used properly. Nope, dont have an idea. Very curious to see what the problem is though.

One question. Do you have Windows 8, and did you overclock your FX-8350? If the answer is yes, wipe your HDD and reinstall Windows 7 or take off your overclock on your FX-8350.

Good call, it could be the reference clock that makes the systemtimer interpretation in windows8 go bonkers.

Reset it to 200mhz, see if it persists.

It's probably your SSD. everything runs Fast on those things....


1. It isn't a lag problem on my laptop that is causing this. I tried Saints Row IV the day before I ran into this problem and after I had this problem with Tomb Raider, I tried Saints Row IV again and it was running much faster than it had the day before.

2. I'm running the RAM at 1600mhz because I've heard that the FX series processors can't handle higher speed RAM. I am also running the latest drivers from AMD

Thanks Batojiri you were right. The problem was that I overclocked my 8320 to 4.2ghz and now at stock everything is running smoothly again.