Thunderbolt 3 TITAN RIDGE on Asus x399-prime-a in Windows 10

Sorry for the late answer.
Here some bullets:

  • The LG monitor uses just one DP connection to show 5k @ 60Hz
  • The TB Card can handle only 4k @ 60 Hz (Support said “according to spec” so i doubt other TB cards can - at least when passing DP through)
  • you don’t need a TB Header if you do the simple cable mod
  • i tried using the TB card as kind of KVM switch, which didnt worked as only one DP port was passed through (might be a software topic)

Best regards, Stefan

Good to know that the cable mod works… are you able to try 2 dp cables from GPU to Titan ridge and a thunderbolt cable from Titan ridge to the 5k…? following article suggests it working for him. Https :// Reason you have the limit of 4K is because of the single cable. 2 dp cables from gpu should give up to 8k support through the card.

I have a ASUS rog maximus xi mb and bought the gb Titan ridge aic. I have a EVGA 2080ti with 3dps in pice slot 1 and put the AIC in slot 3. Paper clipped pins 3 and 5 like the picture in this thread. Was able to install the gb TR drivers and the device appears as a Thunderbolt™ Controller 15EB. Used the same tb3 cable tested between MacBook Pro and LG 5k (1st gen) and ran from AIC to the LG 5k. no luck - no sign of life on monitor or any device recognised in windows. Tried different combinations of the 3 dp in graphics card to the mini dips of the aic, and both ports of the TB3 but still nothing. Any suggestions…? One other question… I am not planning on needing the usb connection from aic to mb, so didn’t plug that in. I also am not running any additional 6 pin power cables to the aic… are those needed??

asus sells an aic for that motherboard that would have been a cleaner solution do you have the dp hooked up from your 2080ti to titan ridge hooked up.

I managed to sort this one out. Working now full 5k, no camera or brightness because the AIC is just sending a 2xDP signal and no data.

Anyway, if anyone else is interested - heres the config:

GC Titan ridge AIC bottom pcie slot, USB2 connected, TBH short pins 3 and 5 (although I think that these are actually pins 1 and 3 from the picture in this thread), No power attached.

Latest intel TB drivers and TB Control Center app.

TB Cable plugged in the correct port on Monitor (yes, when I was testing different cables when not working, plugged in wrong port by accident!)

Monitor works fine in posting, after sleep etc… all good!

Windows reporting 5120x2880 60Hz 8bit RGB SDR… Next thing is to work out why only 8 bit colour instead of 10bit, and a brightness and colour adjustment application…

I have just install my titan ridge to my z390 E ASUS . The mother board does Not have thunderbolt header so I only connected the pcie power 6 pin . I can get my lg ultra fine to work in 5 k but when I turn the computer on and off it doesn’t come back on unless I unplug power from the lg 5kg monitor and plug it back in .

Any help with why it won’t just turn on when I power up the pc ?

@Vince_Ra, I believe that since you do not have a THB on your MB which would control such behaviour, you need to short pins on the thunderbolt header cable - there is a picture of this at the start of this thread showing exactly what to do.
BTW, you shouldn’t need power to the Titan ridge unless you plan to charge things etc… you automatically get up to 75W from the slot on your MB anyways. I have the USB cable supplied with the TR card also plugged into a USB header , but I’m not sure that this actually does anything …

Ok so do to the short pins do I need to solder it or is it just a wire plug in ?

So doing the short pins allows it to start every time you power up the pc ?

I just used a cut down paperclip inserted in the THB cable end as it was easier to do (as did hgc126st in his picture).
And yes, I get the LG showing boot screen from start, can sleep and resume - everything as normal, aside from camera, speakers, mic, usb ports and brightness controls, which is because the DP signal from the Titan Ridge doesn’t contain data to connect to the USB hub in the LG, just contains display signal.

Hello folks first post here. Im looking to buy the tr40 gigabyte Designare and the 3960x for my recording audio and visual studio . I am looking at the Designare because it comes with the TB Titan ridge but would also like 10gb ethernet… so I was wondering if there is an other board that supports both and then I could buy the Titan Ridge separately … any help would be most gratefull . also liked the fact that it comes with the 4 mv2 ssd raid card.

tr40 Gigabyte Aorus Xtreme comes with dual intel 10G ports, THB header on the MB and the 4 mv2 ssd raid card; you’d still need to buy the TB Titan ridge AIC but you have everything you need on the MB

Thank you nbartowski . hmmm decisions… :money_mouth_face:

Hey guys, I’m having issues with the titan ridge. It is on a asus sabertooth x99 motherboard, with a TB header. I can see it on windows and thunderbolt software see the card and both tb ports.
But I can’t plug anything to it, it just won’t connect (thunderbolt display screen, mini display screen, usb c key, ect…).
I see that a lot of you made a jumper cable for the header cable, since I have a tb header on the mothedboard I don’t need it right ?
Any idea why it is not working ?

Some news here, I tried the jumper cable trick and it did not work for me, sadly. Next step maybe a clean windows install ? If someone have a better idea I’ll take it.

A step have been made today, I made a clean install and I am now on window 10 v.2004, same configuration as before with intel legacy drivers.
Now when I plug a screen with a thunderbolt 3 to thunderbol 2 converter, the converter appears in the device manager and I here a bip. But not the screen (who doesn’t turn on neither) and nothing appears in the thunderbolt software.
I first tried with an usb-c key and it did connect and I could read it (still nothing on the thunderbolt software), but when I plugged the screen it stopped working and it is not comming back.

I am out of ideas and the gigabyte support is completly awful. Anyone has anything ?

Hi Cafeserra, Did you get it to work ?

So I have an Asus Rampage VI Extreme Encore board, it’s a X299 chipset board.
So I have a Universal Audio Apollo Twin X audio interface with Thunderbolt 3 connector.

So my question is if I get the Gigabyte Titan Ridge REv 2.0 card, will it work ? My board doesn’t have a Thunderbolt header. I read on the forums that ppl shorted Pin 3 & 5 on the thunderbolt header cable that comes with the card.

My question question is, Asus also have a Thunderbolt 3 card, it’s called ASUS ThunderboltEX 3-TR. Anyone knows if tthis Asus card has that same 5pin cable? so If i get this Asus card instead of the Gigabyte, I can short the pins.
Any infos would be appreciated it. Thank you

i have several gigabyte cards. but my board has the header, you can use gigabyte on asus boards. i have been for years.