Threadripper CPU spikes

Hi all,

I’m also suffering from the PCIe bus errors mentioned here Threadripper & PCIe Bus Errors and pci_aspm=off seems to make them go away. But my threadripper system has some weird performance characteristics that I don’t have the knowledge to debug. My problem is that quite often I experience system CPU usage spikes. The problem gets worst after waking up from suspend (to RAM). Linking executables also takes quite alot of time. I suspect there is some I/O issue.

  • I’ve tried many kernel versions (up to 4.15.2) and nothing seems to help.
  • I’m booting using Legacy mode (UEFI is disabled from bios).
  • Apart from CPU+mobo+ram+PSU my workstation is the same as my older setup that used to work fine. Same HDDs, SSDs, GPU, software

Anyone else experiencing similar issues? Or do you have any idea how to debug the issue? Thank you in advance.

What motherboard?

It’s the Gigabyte AORUS Gaming 7 with the latest bios (F3g)

As I mentioned before when linking executables I observe high system CPU usage and the process takes longer than it used to. So I tried to link on my HDD instead and it was faster. I suspect x399 is allergic to my Samsung 840 EVO SSD.