Return to Level1Techs.com

Threadripper and SR-IOV

#1

Hi, was hoping to play around with SR-IOV on Server 2016 on my 1950X/Gigabyte Aorus 7 board, and even though I have SVM enabled and Hyper-V works, when I run:

PS C:\Users\Administrator> (get-vmhost).IovSupportReasons

I get:

SR-IOV cannot be used on this system as the PCI Express hardware does not support Access Control Services (ACS) at any root port. Contact your system vendor for further information.

Which indicates my bios does not support ACS. Does anyone know if that’s an option in the gigabyte F11 (most recent) bios or am I out of luck. I don’t have an ASRock board to test, but after some googling, it sounds like ASRock boards have the best virtualization support. I really don’t want to buy a new board to test SR-IOV, so hoping I’m just missing something here! Thanks, Hammer

0 Likes

#2

It is posible that it is not enabled in the BIOS.

I don’t know if gigabyte has a different name for it, but you want AMD-vi enabled.

AMD-vi is AMD’s implentation of IOMMU, and IOMMU is what is controlled by ACS.

0 Likes

#3

Thanks…I have IOMMU set to enabled, but still getting the message above.

0 Likes

#4

there is a separate sr-iov option in most uefis, it does work check under the amd cbs/pbs options?

0 Likes

#5

Hi, thanks…yes, I checked under AMD CBS and nothing that pertains to SR-IOV or AMD-v etc…

Love the videos!

0 Likes

#6

Hi, just wanted to follow up to see if anyone has any info on which threadripper mobos support SR-IOV. Thanks!

0 Likes

#7

there is a separate SR IOV option, I think it’s under advanced.

0 Likes

#8

Thanks…for the life of me, I can’t seem to find it. Anyone know where it’s buried? :slight_smile: Thanks!

0 Likes

#9

Hi, still trying to get SR-IOV with Threadripper. Is there a motherboard known to support SR-IOV? Thank you!

0 Likes

#10

I’ll ask

0 Likes

#11

I seem to recall an option on my X399 Taichi.

I’ll check when I get a minute.

0 Likes

#12

Deja vu… kinda. I remember having a similar frustration when I was trying to get PCI passthru working (pre-VFIO) back during the 970 chipset days. Mobo manufacturer’s rarely fully document their bios so you can’t download their manuals to check and it’s even less likely they’d list it in the specs on a consumer board. It’s up to google and finding someone’s first hand xp. :confused:

I just looked quickly but it seems that there a lot of people asking your question but no answers at first glance. Of course the algorithm assured me that IOMMU is supported since a majority of the results didn’t even contain SR-IOV in them or weren’t the main topic… the algorithm… so helpful, right?

edit Incidentally I did settle on a ASRock board at the time, one of the few that supported IOMMU. But alas, VGA passthru wasn’t really ready at the time despite recompiling the kernel with new options. Nowadays it seems IOMMU support is all but guaranteed, but if I was looking for something hard to find my bias would definitely be to look to ASRock. Who knows though?

0 Likes

#13

Um, if it helps, the X399 Taichi has SR-IOV in the UEFI.
On the Advanced page, under North Bridge Configuration.

Because @sgtawesomesauce looks to have been distracted :slight_smile:

It seems upon looking at it, that I had it disabled, but had been running a gaming VM for a while without :man_shrugging:

2 Likes

#14

SR-IOV isn’t needed for VFIO passthru. It’s a separate virtualisation standard that was most commonly for NICs that had multiple ports. It allows you to sort of slice up the resources of a PCIe device and pass the portion(s) through to a VM. In the case of GPU’s the idea is to take a certain amount of it’s compute to passthru a virtual GPU to the VM. Presumably leaving some leftover for the host or even other VMs. To date it’s mostly used in the enterprise/cloud. Nvidia has a similar tech that is proprietary and has an insanely expensive software stack to buy, whereas AMD uses SR-IOV in their solution. At least that’s my understanding of it.

2 Likes

#15

I went to sleep. I’ll be checking it today, I am just doing father’s day things right now.

0 Likes

#16

No worries, was only kidding

1 Like

#17

My understanding is the ROM BAR panic still exists (UEFI won’t POST with a SR-IOV card) on Threadripper, so it might be a while before real SR-IOV support comes to Threadripper.

Epyc boards though support SR-IOV cards.

0 Likes

#18

I couldn’t say for sure.

Is this issue specific to GPUs or do all devices suffer from it?

0 Likes

#19

Asrock boards have this and some gigabyte boards do. Sr iov will work for nics but not gpus because of the pcie rom bar space.

MSI boards do not have the option but I’ve emailed them for a special bios that unlocks the option.

0 Likes