Think my mobo just died

Quick backstory. Got 6700k and z270g strix mobo to build myself a new system. Have been using it for a month with no issues.

Had been using a basic cooler on it until I recieved all of the parts to build a custom loop for the system. Built the loop and leaktested it outside of the system, put it into the system, then leaktested it again (overnight the first time, 3 hours the second). No drips or anything.

Went to turn on the system and it bootlooped a couple of times after hanging on the VGA post led. Shut it off immediately after noticing the pump wasn't running.

Switched headers from the dedicated pump header to one of the two cpu fan headers (and put the two rad fans on a splitter). Turned on, pump turned on, but this time none of the post leds lit up, the led logo stayed on what I had it set to be when the mobo was off, my other case fan and the gpu fans (windforce 270x) didn't turn on.

Switched gpu (msi 7770), had the same issue. Tried a different psu and with the mobo out of the case with just cpu and ram installed (tried both sticks in a different system to be sure and they are fine) with the same result.

No physical damage to the mobo that I could see (other than a scratch on the vrm heatsink that was there when I recieved it).

Is it safe to say that it is dead? And is ASUS RMA service as bad as I've heard?


and the cpu could also be damaged from the pump not working if it got too hot while boot looping.

This is what I'm most afraid of. My brother has a skylake system as well that I may test my CPU in to see if it bit the dust as well. Not exactly how I had hoped to spend my evening.

UPDATE: CPU tested and works in a different mobo. Guess it's time to hope and pray ASUS doesn't waste my time.