Return to Level1Techs.com

The small linux problem thread

linux
helpdesk

#1501

That’s why I run a LTS as my core OS and then put everything in LXCs. Anything goes wrong on the host I just migrate my containers over, they pick up the same IPs, and everything works.


#1502

Might have to get some more details about this later on, but the problem wasn’t so much Fedora’s fault, but the fact that the system crashed. I don’t know if it’s a hardware or software fault here…


#1503

Really don’t see how it could be a hardware problem. Physical data corruption wouldn’t look like that. Yes it crashed, but it’s supposed to recover from that.


#1504

Could have been one of those btrfs issues that cropped up the other day… I was trying to update away from 4.17.7


#1505

Sure, but that’s a software problem.


#1506

I wasn’t disagreeing.


#1507

I haven’t used KDE in a while. I installed XFCE because KDE might be fucking with some games, and IS fucking with some of my app UI’s. But the login screen is kwin, or whatever its called.

I’m in netrunner rolling (arch / manjaro). I like SDDM, so can I just… install SDDM and not muck with scripts and crap?


#1508

I thought KDE used SDDM…


#1509

Nope it has an integrate login manager.

It used to, but with a lot of work pushed through recently it does it all itself.

Also I ask this because I can’t select something else I can only use KDE at login.


#1510

Ah, for some reason I remember something about KDE and SDDM. Maybe it was a distro using it by default.


#1511

Probs manjaro lol.


#1512

kde on fedora still uses SDDM iirc

Can also use whatever login manager you want.


#1513

Yep, just checked:

Screenshot_20180803_215821


#1514

Kwin is KDE’s Window Manager, which is what gives you all the eye candy.


#1515

I still can’t select other DE’s / WM’s in Netrunner at login.


#1516

Is the option to change to another DE missing? Or is it always loading KDE when you pick something else?
Is there a “Change Session” button"?


#1517

Theres no menu’s for other sessions at all. Complete delete.


#1518

I’m guessing it is the theme that is missing the option. Just to check something…

Go into KDE System Settings > Startup and Shutdown > Login Screen (SDDM) then the Advanced Tab. Click Auto Login, the Session tab is now accessable. Does Xfce show up as a session? If it does, unclick the Auto Login, (or keep it and pick XFCE to be the default) go back to the theme tab and change to the stock Breeze SSDM theme, if it isn’t installed, click the Get New Theme at the bottom and pick a different theme.


#1519

Uhhhhh

Yeah so thats not there at all, and because I’m not a KDE user, I dunno how I’m supposed to add it?


#1520

The theme is being a butt and not showing the ability to change your DE. Choose a new theme.