Return to

The small linux problem thread



Yeah, I had tried that with no luck. Just on a whim I decided to hook my spare keyboard and mouse up to the laptop, and it worked. Was able to type and move the cursor. So, I’m updating now. :slight_smile: Hopefully all is well again after the updates.


Whats the minimum kernel that supports nvme?


it depends on the distro but its technically supported from 3.3 and up.


…annnd it’s not. Turning the trackpad off and on again in the Settings fixed it, but not sure how to go about getting the keyboard back in service.


Hmmm. I don’t really know. Can you post the logs? journalctl -b and systemd-analyze blame and systemd-analyze are your friends.

Trying to search for clues. Linux has so many moving parts that it could be any number of things that’s causing the problem.


dmesg | grep error

might reveal anything going wrong.


I’m having a problem with HyperX Stinger Cloud microphone on Ubuntu 16.04 using Gnome.
In Sound Settings I can see the input change from Internal Microphone to Microphone but when I speak there is my voice is not detected.
I tried muting and unmuting the input volume. Nothing.

Tried the headphone with my phone, works fine. Headphone sound ok, mic detected. Discord works.


check its also not muted in pulse audio.


Pusle Audio also does per application profiles. Plug in the Mic, set it as default, and then launch the application. That has been an issue for some games that I had in the past.


Ubuntu 17.10. VLC is set as the default for music and video in settings, but audio files still open with Banshee when opened from the file browser. Same problem existed before upgrading from 16.04 LTS.


Go to System Settings and change the defualts to what ever applications you like.


Already done. Still opens audio files with Banshee.
Screenshot from 2017-11-13 10-27-19


That is strange. I do not use Ubuntu. I use Debian.

I would assume that there is a config file in your home directory that you can modify. If they are doing something with the mime type db, then you may need to doba dpkg --reconfigure on what ever .deb package supplies it.


probably just means that the “music” section of the default app dialog, doesn’t cover the filetype your opening. as in “music” is MP3, M4a, and Wave files, which doesn’t include flac, and so on. it should be as easy as just going in the the file’s properties and setting the default program in that dialog, and then repeating for each file as you find them opening the wrong program.


Did not think of that. That is the simple solution.


MP3 files, which you’d think would be included under “Music”… Just tried through the Properties dialogue, but when I click the “Set as default” button, nothing happens. I also tried setting other apps as default with the same results. It’s acting like Banshee is the only one that can be set.
Screenshot from 2017-11-13 12-46-00


Sorry if it has already been posted (I’m a bit behind in this thread) but I gave this a shot on my F26 machine. Worked straight out of the box. It even has the option to install the canary build.


Thanks, but I’ve since abandoned Fedora due to dracut issues.


wow, that is so odd. umm, then I would say look into what Mastic_Warrior said. I know that there is a command you can run to set defaults in the terminal, I don’t know if it works the exactly the same on ubuntu as it does on debian, but might help. I would also look at the advanced settings of your DE maybe it is locking the program, like Dconf-editor or something.

terminal command to set defaults was this

sudo update-alternatives


what issues? granted ive never used dracut but im intrugied