Return to Level1Techs.com

The small linux problem thread

linux
helpdesk

#714

Dracut is a pain in the ass when it comes to configuring kernel modules to be loaded in initrd (or whatever they call it now) and the documentation is sporadic at best.


#715

i can see that. neat. thanks for sharing.


#716

Sorry if you aren’t the OP for this issue, but could you use the context (right mouse button) menu then “open with” to open an MP3 once to confirm it will open in VLC, and maybe set as default that way?


#717

Haven’t been able to find anything in here.

This is my next try. Away from that machine until this evening.

This is the standard way that should work, but doesn’t. Something has the defaults locked up. Going to try the above to reset all defaults on the system; hopefully that clears it out.


#718

Anyone know if it’s possible to use multiple tags in lvm in the following way:

lvs @tag1 @tag2 shows anything with tag1 or tag2

I only want to see things that have tag1 and tag2


#719

Gave this a try just now. If you’re reading this in the future, the command I ran to choose all of the defaults “update-alternatives” controls, was this:

sudo update-alternatives --all

Audio files was not among the list. I tried removing VLC and it’s dependencies, then reinstalling. Same results. I hate to have to try the same with Banshee and loose the current config, but this issue just might be annoying enough…

edit Backed up banshee.db, removed, and VLC took over as default. However, that default cannot be changed. So it has nothing to do with Banshee or VLC. Media file defaults seem to be stuck on my system. The investigation continues…


#720

wow, well I am at a lost there. I don’t think I have run into anything close to that kind of a problem. well I wish you the best of luck fixing it and would love to hear what the problem is / the solution when you figure it out.


#721

Hi.

For some reason usb audio kills VM usb and host usb partially. Everithing is fine until i try do play sound, and its not only one usb dongle i have tried two different usb audio devices both crash usb

OS: Fedora 25 ( NPT Patch )
CPU: Ryzen 7 1700X

Any ideas ?


#722

A dump of dmesg when the device crashes.

What is the USB device?
Is it plugged into a USB hub?
Are you passing throught the USB device or the IOMMU group of those USB plugs?

You need to provide some information to work with.


#723

I am passing throught usb device ( no iommu )


#724

What VM manager are you using? KVM, XEN, etc?


#725

So I repaired my laptop this weekend and I tore down everything to the motherboard. (Pesky jiggling power adapter issue. For some reason, Windows freaked out and would no longer boot, and I tried recovering and the OS just lost it. So I said to hell with it and booted up a Debian 9 ISO and installed it.

I’m curious to know if I am getting all the right software for my device now… Do I need any drivers? Where can I find drivers? Further, what should I look at to determine that my CPU is being utilized correctly and software is 100 % up to date?

Some people are mentioning Stretch but stretch is not included with my distro. Any help here would be great because I don’t want to sit through another lengthy windows install and a day’s worth of updates on my low speed connection.

– Debian 9 AMD64 ISO (pulled from debian .org 2 days ago)
– Dell Precision M4600 Laptop (Mostly Stock)

  • Core i7
  • 64 GB minicard SSD

#726

EDIT: FIXED, kernel version was the problem. Compiled kernel 4.13.14 stable with npt patch and voilaaa :slight_smile:

dmesg

937.703134] uurb->buffer_length is too short 6144 vs 0
[ 937.703143] ------------[ cut here ]------------
[ 937.703149] WARNING: CPU: 6 PID: 11126 at drivers/usb/core/devio.c:1583 proc_do_submiturb+0x9ca/0xd80
[ 937.703150] Modules linked in: vhost_net vhost tap snd_usb_audio snd_usbmidi_lib snd_rawmidi btrfs xor raid6_pq ufs hfsplus hfs minix msdos jfs xfs fuse xt_CHECKSUM iptable_mangle ipt_MASQUERADE nf_nat_masquerade_ipv4 iptable_nat nf_nat_ipv4 nf_nat nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack libcrc32c tun bridge stp llc ebtable_filter ebtables ip6table_filter ip6_tables sunrpc vfat fat snd_hda_codec_realtek snd_hda_codec_generic snd_hda_codec_hdmi snd_hda_intel snd_hda_codec edac_mce_amd snd_hda_core kvm_amd snd_hwdep kvm snd_seq snd_seq_device snd_pcm snd_timer snd ccp joydev soundcore crct10dif_pclmul crc32_pclmul ghash_clmulni_intel tpm_tis tpm_tis_core tpm sp5100_tco shpchp i2c_piix4 pcspkr wmi_bmof amdkfd amd_iommu_v2 radeon drm_kms_helper igb ttm mxm_wmi drm crc32c_intel ptp
[ 937.703175] pps_core dca i2c_algo_bit wmi vfio_pci irqbypass vfio_virqfd vfio_iommu_type1 vfio
[ 937.703179] CPU: 6 PID: 11126 Comm: qemu-system-x86 Not tainted 4.13.9npt-patch #1
[ 937.703180] Hardware name: Micro-Star International Co., Ltd. MS-7A32/X370 GAMING PRO CARBON (MS-7A32), BIOS 1.97 09/20/2017
[ 937.703181] task: ffff8e6ba82e8000 task.stack: ffff9d5b43570000
[ 937.703182] RIP: 0010:proc_do_submiturb+0x9ca/0xd80
[ 937.703183] RSP: 0018:ffff9d5b43573d30 EFLAGS: 00010286
[ 937.703184] RAX: 000000000000002a RBX: ffff8e6b9e8a2fc0 RCX: ffffffffb0e59188
[ 937.703185] RDX: 0000000000000000 RSI: 0000000000000092 RDI: 0000000000000247
[ 937.703185] RBP: ffff9d5b43573db8 R08: 0000000000000516 R09: ffffffffb1312f00
[ 937.703186] R10: 0000000000000200 R11: 0000000000000000 R12: 0000000000000001
[ 937.703187] R13: ffff8e6839a6ae40 R14: 00005558fd9e43b8 R15: ffff9d5b43573e00
[ 937.703188] FS: 00007f1c50e5ed80(0000) GS:ffff8e6bae780000(0000) knlGS:0000000000000000
[ 937.703188] CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[ 937.703189] CR2: fffff80b16053010 CR3: 00000000b0b86000 CR4: 00000000003406e0
[ 937.703190] Call Trace:
[ 937.703193] usbdev_do_ioctl+0xa45/0x11b0
[ 937.703196] ? compat_poll_select_copy_remaining+0x120/0x120
[ 937.703197] usbdev_ioctl+0xe/0x20
[ 937.703198] do_vfs_ioctl+0xa5/0x600
[ 937.703200] SyS_ioctl+0x79/0x90
[ 937.703202] entry_SYSCALL_64_fastpath+0x1a/0xa5
[ 937.703203] RIP: 0033:0x7f1c476cf847
[ 937.703204] RSP: 002b:00007ffeb888c2f8 EFLAGS: 00000246 ORIG_RAX: 0000000000000010
[ 937.703205] RAX: ffffffffffffffda RBX: 000000007ecb3002 RCX: 00007f1c476cf847
[ 937.703205] RDX: 00005558fd9e4380 RSI: 000000008038550a RDI: 000000000000003a
[ 937.703206] RBP: 000000007ecb3000 R08: 00007ffeb888c220 R09: 0000000000001800
[ 937.703207] R10: 00005558fe60bb80 R11: 0000000000000246 R12: 00005558fc049c10
[ 937.703207] R13: 00005558f8e12060 R14: 000000000000000a R15: 00005558fc049a00
[ 937.703208] Code: 00 c7 45 a8 00 00 00 00 48 c7 45 b8 00 00 00 00 0f 85 27 f8 ff ff 89 c2 48 c7 c7 e0 67 d0 b0 c6 05 b5 d2 9c 00 01 e8 87 a8 ac ff <0f> ff 49 63 47 18 e9 07 f8 ff ff c7 45 8c 00 00 00 00 c7 45 98
[ 937.703222] —[ end trace a48a960fff14b3d3 ]—
[ 937.704446] xhci_hcd 0000:03:00.0: AMD-Vi: Event logged [IO_PAGE_FAULT domain=0x000b address=0x0000000000000000 flags=0x0000]

I am using KVM

QEMU emulator version 2.9.1(qemu-2.9.1-2.fc26)
Copyright © 2003-2017 Fabrice Bellard and the QEMU Project developers

dmesg error comes when i try do play some sound in guest


#727

When i installed Fedora 27 kde it would have a bunch of screen bugs / Artifacts and it has pretty terrible ghosting. Its fully up to date. I have a gtx 1070.
Edit im using the Nvidia drivers not from nvidia.


#728

Does somebody know how to prevent pulseaudio from being loaded in my VNC X session?
When I log in into my normal X session, I don’t have audio anymore until I stop the vncserver.


#729

Never used vnc, but what comes to mind could vnc be displayed as its own audio output? Check the settings in pavucontrol to find out for starters.


#730

Running a system wide PulseAudio instance utilizing systemd solved my problem.
(https://possiblelossofprecision.net/?p=1956)


#731

My RX 560 is showing up as a 460. That normal?


#732

More or less, yeah. Since the 500 series is just a rebrand, the base chip is the same.

If you do lspci you’ll probably see it show up as RX 460/560 or something of the like.


#733

Yeah, shows up as a Radeon RX 460 rev e5.