Return to

The small linux problem thread



Have you setup a bridge connection?


I just set up a bridge network following this guide:

First question: the IP address for the bridge. Should it be an address on the physical network (192.168.0.x), or should it be removed (192.168.1.x)?

Second question: what is the process for creating a virtual network with the bridge adapter?

I have written and deleted this response about four times now over the last few hours without actually posting it. I have tired quite a few things to get this to work, all with no success. So, rather than make a huge response with all my failings I’ll just keep it simple with the two questions.


For what you are wanting to accomplish just put the bridge adapter on same network. Let your VMs use bridge adapter and get an address on same network. That is how I would accomplish this. Do not worry about setting up a virtual network on bridged adapter.


Thanks. That was exactly what I needed to do. For some reason my brain was stuck on needing to go through the virtual networking garbage.

I did, however, need to use the second NIC for the bridge. If I attached the bridge to the primary NIC it took the IP address and applied it to the bridge. This removed network address to the host.

This guide helped too:

What’s weird is that I can’t restart the network service (systemctl restart network). This happens:
Screenshot from 2017-10-28 12-34-05

This made it so with every change I made to the network config I had to do a complete reboot. Which sucked.

But the VM is now up and can access the NFS share and is accessible from other systems. Cool. Thanks again.


Yesterday I did a pacman -Syyu and now I get this when I try to boot into Manjaro.


I am pretty sure that this has to do something with my graphics card from what I was able to google but everyone recommends to switch to the IGP and then upgrade to nvidia drivers but I can’t use the IGP because I don’t have any DVI connectors and my Display Port doesn’t work on the monitor side. Can I fix this problem without the IGP solution?


I have this issue on my CentOS 7 laptop where my CPU is at 100% use just by browsing firefox. I’m on a 32gb msata Dell precision m3600, not a vm.


Do you have VGA connector at least?. Or use a dvi to vga adaptor.

Otherwise, you need to run a Live distro or recovery mode disc to get in there and admin that install.


If I set up a Yum repo on a server, is there a way to log IP addresses accessing the yum repo folder?


Sure but that depends on what webserver you are running.

Is that a new question or related to current issue?


New issue/question.

It’s running Apache. Technically the server I’ll be putting it on is already an SFTP server (centos) that clients connect to. I just want to log the clients pulling from the specific folder that I’ll be putting my yum repo in. Not everyone that is accessing the box (since they also pull/push to the SFTP server.

A couple clients said they want a yum repo to update machines with but if down the line only a couple people actually use it, I want to know if it’s really worth the effort to maintain the repo.


I solved the problem by booting into console instead of KDE and then I switched drivers from there and on the next reboot everything worked fine with the nvidia drivers.


Thanks for providing the fix to your issue. Follow ups like that make this thread valuable.


Linux doesn’t have an equivalent to holding the middle mouse button in Windows and scrolling with that.

It’s great and I miss it terribly in Linux.


I believe that you can map that using xmod if you use xorg.

Good luck.


That can be done with the apache access log. Shows client IP, request URI and timestamp.


Right, but I only want to log the people using just the repo folder. not everyone accessing the website to pull other data that they use it for. Is that possible to set up?


Yes. I suggest you start looking at some documentation. I have not messed with apache in a while, but I have personally done this for someone.


This is probably tangentially related to Linux, but I thought I’d ask here instead of making a whole new topic.

I bought an ‘international’ Moto G5 (XT1671) a few months ago. It’s a great phone. I don’t have it rooted, it does everything I need it to. Only problem I’m having is updates. Does anyone know how to change the software channel? It’s set to ‘retla’ which I assume means Retail Latin America. I’d like to set it to North America to see if I get updates, because the last security patch is from May 1 2017.

Anyone know about this?


Absolutely is, maybe we should have a general “small questions thread” for each of the larger categories. That said, I have no problem with this question here.

I couldn’t find anything for the G5, but on the G4, there’s this thread. It may be similar:

EDIT: Digging deeper, it seems that all the moto phones use the same software channel identification system, so the G5 should be similar. This page has all the channels that were available for the Moto Z Play:


Thanks for the links. I got the unlock code for the bootloader, but I haven’t unlocked it yet. Now I am going to do some more research on what I can do. The first option feels, I don’t know, dirty somehow. It’s a lot of trouble to go to, slipping in a fastboot command in while it’s flashing or something. Sounds like there’s a lot of room for error.

The second options seems interesting: just flash the OTA updates through recovery. I’ll do some research on downloading those and flashing through recovery and adb.