Return to Level1Techs.com

The small linux problem thread

linux
helpdesk

#2024

Thanks but I’d like to avoid those risks. I really should learn to make lvm snapshots, but this isn’t the best time to practice this! My dnf.conf doesn’t have keepcache=1, plus it has what seems like the opposite: clean_requirements_on_remove=True

More importantly, what would forcing dnf accomplish if the update to that package doesn’t exist, and is it possible to check for its existence in the repo?


#2025

I’m new to dnf (though not rpm) so I may not have all the answers. The dnf cache is in:
/var/cache/dnf
You could do ‘sudo find /var/cache/dnf -iname “glibc*.rpm”’ to see if any glibc packages are cached. Unfortunately I don’t know how to search the repos for a specific revision, though my understanding is that the vast majority of repos only have the very latest revision of packages.

I’ve been using dnf for a little under a year now, and my personal experience has been that aptitude is generally better. Bet that’ll raise a few hackles…


#2026

sudo find /var/cache/dnf -iname “glibc*.rpm” returns nothing. /var/cache/dnf contains directories for each repo, and I checked in the one for “updates” and there are just a few packages and nothing for glibc.

In any case, I’ll just wait it out. This type of update problem happens regularly for packages from rpmfusion such as virtualbox and chromium (due to a package with “bad” codecs). Usually after about a week, the missing package appears and the update is successful. I’m just surprised it’s happened with a core package like glibc from the updates repo.


#2027

I restored from a month old backup using dd, and now have Fedora 28 installed. My audio issues are also gone.

Moral: Always backup your OS as well as your data.


#2028

I’m sorry I missed your reply. I’m using AMD Vega 64 and Samsung 1TB 970Evo on Asus Crosshair VII Wifi.
With new Ubuntu 18.10 install I again had troubles waking from USB.
step1 – sudo su

step2 - grep . /sys/bus/usb/devices/*/product
take note the usb buss number between device and product, mine shows
/sys/bus/usb/devices/3-2.1.1.2/product:G Pro Gaming Mouse
if you are not using a hub it may show just (usb1,usb2,usb3,usb4,usb5,usb6,usb7,usb8)
between the devices and product.

Step3 - lsusb which will show buss and product ID’s
take note of the 4 digits before and after the colon, mine shows
Bus 003 Device 006: ID 046d:c085 Logitech, Inc.

step4 - sudo nano /etc/udev/rules.d/10-wakeup.rules
add this line replacing the idVendor and idProduct from step 3 and the usb buss number between devices and power taken from step 2

ACTION==“add”, SUBSYSTEM==“usb”, ATTRS{idVendor}==“046d”, ATTRS{idProduct}==“c085” RUN+="/bin/sh -c ‘echo enabled > /sys/bus/usb/devices/3-2.1.1.2/power/wakeup’"

step5 – reboot and run grep . /sys/bus/usb/devices/*/power/wakeup to verify your device shows “enabled”


#2029

What kernel are you using?


#2030

Hi there. So AMDGPU drivers are still broken after two months of waiting. My main monitor is stuck at 60hz instead of 95hz. As everything I tried failed to get it to work I would like to make a bug report.

Where can I do that and how? This is going to be my first time ever doing any kind of linux related bug report.


#2031

what have you tried to get it to work - I have amdgpu with multi monitors and am currently overclocking both without difficulty.

If you want to try to debug this again:

  • What Distro are you using?
  • X11 or wayland?
  • What GPU?

The problem you are having could be a wayland/x11 issue instead of the driver.


#2032

Fedora 29, X11, Vega64 and I am on the latest kernel 4.19.6-300.fc29.

Not to repeat myself. Here is my thread: Missing refresh rate for my monitor

I could add that I got what I think is a good Modeline out of the windows radeon display information. I used some modeline calculators online to get from 689.50 G.Pixel to 503.60 G.Pixel which is in windows and working.

Also Ubuntu 18.04 liveUSB with it’s ancient kernel works out of the box. That means anything they did in the past half year broke.


#2033

Ah I see - sorry didn’t know you had a thread going already. Would recommend trying 75hz to see if we can increase the refresh rate at all.

what do you get if you run:

gtf 3440 1440 75

#edit: reason I ask with gtf is I get different results than cvt and the cvt results doesn’t work with my machine.


#2034

I tried but it doesn’t work. The best part is I can’t even go past 60hz. Even 61hz results in a black screen or not even applying it out right. With cvt or gtf.

There is just something wrong with the open source drivers. And I have the feeling if I don’t report this somewhere it wont be fixed as these korean monitors are pretty uncommon.

I am baffled as to how Wendell didn’t encounter this problem. He has lots of them and I saw exactly this one in his last videos in the background. Then again he is running Windows 10 as far as I saw it.


#2035

I’m totally baffled then.


#2036

Thank you for helping anyway. If this won’t go anywhere, I have a few options. Installing AMDGPU-PRO but there is almost no tutorial guide for it. Swap vega for my GTX 980ti and install proprietary drivers. Or go back to Windows. Either way I will do something till the end of the year. I cannot stand this laggy mess anymore.


#2037

4.19.8-041908-generic
I was able to get my system waking from the usb mouse, I had to change the buss from usb3 to 3-2.1.1.2
From
“ACTION==“add”, SUBSYSTEM==“usb”, ATTRS{idVendor}==“046d”, ATTRS{idProduct}==“c085” RUN+=”/bin/sh -c ‘echo enabled > /sys/bus/usb/devices/usb3/power/wakeup’
TO
ACTION==“add”, SUBSYSTEM==“usb”, ATTRS{idVendor}==“046d”, ATTRS{idProduct}==“c085” RUN+="/bin/sh -c ‘echo enabled > /sys/bus/usb/devices/3-2.1.1.2/power/wakeup’


#2038

Turns out it’s a bug: https://bugzilla.redhat.com/show_bug.cgi?id=1658497


#2039

Interesting. Thanks for posting the fix.


#2040

How can I get Discord on Linux in its own window or as a tint2 tray widget without installing the close-source discord client? I don’t always have a web browser open and tend to close discord tabs by accident and not notice until hours later.


#2041

There’s a libpurple discord plugin that should let you use it with pidgin


#2042

Thanks, got it installed in Debian by compiling from source and adding the plugin to pidgin. It doesn’t seem to show unread messages in the tray icon, pull chat history, profile pictures, or sort messages by last activity. I don’t think this works for me.

I think a more elegant solution would be to have a separate firefox install/profile that has discord as the homepage. Running “firefox --profilemanager” to make a new profile then "firefox -p " would accomplish this. No tray icon, but you can enable desktop notifications to get nagged as new messages come in.

EDIT: A far simpler option is to open the discord web client in firefox, right click the tab and click “pin”. It will permanently be on the tab bar, can’t be closed, and will show unread messages through the little red number/circle in the tab icon. If you have desktop notifications enabled in discord and your OS, you will also get a toast notification.


#2043

I would recommend submitting an issue on the purple-discord github, maybe he can add those features at some point.