Return to Level1Techs.com

Missing refresh rate for my monitor

Just yesterday switched to Fedora 28 (mesa 18.0.5). I have 3 monitors and only the AOC has it’s full range of refresh rate.

  1. LG
  2. Crossover
  3. AOC

The most infuriating is my main monitor crossover 3412um 3440x1440 95hz which is only going up to 60hz. Any attempt to go over 60hz results in xrandr: Configure crtc 0 failed except 95hz which results in a black screen and after that flashing of my AOC monitor.

cvt resutls for 3440 1440 95:

# 3440x1440 94.95 Hz (CVT) hsync: 144.61 kHz; pclk: 689.50 MHz
Modeline "3440x1440_95.00"  689.50  3440 3728 4104 4768  1440 1443 1453 1523 -hsync +vsync

I had the idea copying windows setting over to linux because all three monitors work there. But the numbers are completely different. Nowhere do I have v./h. porch or v./h. sync width on linux. Only thing is the G.Pixel Clock is 503.60 and in linux I think it’s the first number 689.50.

Radeon settings:

Everything I tried resulted in the xrandr: Configure crtc 0 failed error.

This is a dealbreaker. I cannot look at this mess of 60hz while using/playing at 95hz for over a year now. Would hugely appreciated help.

You might try and install read-edid and then do a get-edid|parse-edid and see what mode lines you get as output.

Pick the one that patches closest and then do something like:

xrandr --newmode "3440x1440_95.00" [OUTPUT FROM edid]
xrandr --addmode DP1 "3440x1440_95.00"
xrandr --output DP1 --mode "3440x1440_95.00"

Isn’t this the same asxrandr which is returning with all the resolutions and refresh rates? Because I am running this program under root and it still needs root…

[[email protected] alphazero1990]# get-edid|parse-edid
This is read-edid version 3.0.1. Prepare for some fun.
Attempting to use i2c interface
Looks like no busses have an EDID. Sorry!
Attempting to use the classical VBE interface
mmap /dev/mem: Permission denied
error initialising realmode interface
do you have full superuser (root) permissions?
I'm sorry nothing was successful. Maybe try some other arguments
if you played with them, or send an email to Matthew Kern <[email protected]>.
Partial Read... Try again

I suggested it just because xrandr had issues with my A409U’s auto-detected EDID’s and was setting it as 800x600 until I did the above, which returned a different configuration than xrandr.

Was just trying a different method of skinning the cat.

My issue was with a 970m so it might be completely unrelated to yours. Only other thing i can think of would be to switch to the other graphics driver (fglrx to mesa or vice versa) and see if it starts playing nice.

1 Like

Finally. After almost 3 months the latest kernel 4.19.9-300 fixed it. Now my monitor works at 95hz. Sweet smooth desktop how i missed you. :D.

1 Like