The small linux problem thread

Easy solution is to install cups-lpd on the Linux system, then print via lpd from XP.

1 Like

No luck with disabling encryption or getting cups-lpd to run on Ubuntu 20.04. Just for fun I tried 16.04 and it works by just disabling encryption.

Now some would argue that 16.04 is a bad idea, but Windows XP is also a bad idea. They both run in VMs on the same host connected via internal network only so who cares.

1 Like

What is the expected max transfer speed of an NFS Share over a residential router? Im clocking in at 15MB/s

Is there a master/ultimate exports file with a list of examples (kinda like the bash_aliases)

Really depends.

That is pretty good. NFSv4 or older?

I would look at the Red Hat docs as they are very extensive. You can mess yourself up if you don’t know what your are doing.

Otherwise, ArchLinux wiki…
https://wiki.archlinux.org/title/NFS#Tips_and_tricks

NFSv4, and i can’t get it to consistently mount. I’m trying move all my SMB shares to NFS.

VMs in the same machine transfer at 50-65MB/s

A post was split to a new topic: How do DUIDs work? (DHCP)

So… I finally got a bit of time on my hand to reinstall my PC, been wanting to do that for way too long…

Anyway, I am running into some issues. So I booted the Fedora KDE 36 Live USB (yes I know it’s technically Beta but… not for long), and was going into the Partition Manager just to check what’s there currently, so I wouldn’t nuke my /home partition, and I’m seeing this:

So when I installed this thing years ago I was wanting to have separate partitions for root and home. But it seems what instead happened is that it created two volumes(?) and put them in a single partition?

Is there any way to rectify that without having to re-format the entire drive?

And if not, is there still a way to get the Fedora installer to install over the old Fedora install without touching the home volume?

I’m a little lost here why this even happened in the first place since I’m pretty sure I was creating two partitions back then but yeah… IDK.


Also another odd issue. I still have a Windows drive in this PC (I shrunk the Windows partition and use the rest of the drive as an ext4 partition for games), and I pulled the SATA plug to be safe during installation.
But now the old Fedora install won’t boot unless I reconnect that drive? I mean… what? There is nothing on that drive that has anything to do with booting, but the system just boots into a maintenance mode instead…?


On another node, like half a year ago I mentioned how DNF seems to have lost track of my manually installed packages. Well, this is what happens when I dnf history userinstalled on the Live USB boot…

[[email protected] ~]$ dnf history userinstalled
Packages installed by user
aajohan-comfortaa-fonts-3.101-4.fc36.noarch
anaconda-36.16.2-4.fc36.x86_64
anaconda-install-env-deps-36.16.2-4.fc36.x86_64
anaconda-live-36.16.2-4.fc36.x86_64
chkconfig-1.19-2.fc36.x86_64
dracut-live-055-8.fc36.1.x86_64
fedora-release-kde-36-0.16.noarch
fuse-2.9.9-14.fc36.x86_64
initscripts-10.15-1.fc36.x86_64
kde-l10n-17.08.3-12.fc36.noarch
kernel-5.17.0-0.rc7.116.fc36.x86_64
kernel-modules-5.17.0-0.rc7.116.fc36.x86_64
kernel-modules-extra-5.17.0-0.rc7.116.fc36.x86_64
langpacks-en-3.0-21.fc36.noarch
libreoffice-draw-1:7.3.0.3-3.fc36.x86_64
libreoffice-math-1:7.3.0.3-3.fc36.x86_64
mariadb-connector-c-3.2.6-1.fc36.x86_64
mariadb-embedded-3:10.5.13-1.fc36.x86_64
mariadb-server-3:10.5.13-1.fc36.x86_64
mediawriter-4.2.2-4.fc36.x86_64

Sooo… thanks DNF?

Possible that lock means its encrypted?

pv is an lvm physical volume. It looks like there’s a luks container in the pv. Decrypt that and you should see your volume group(s), logical volumes and filesystems.

2 Likes

Yeah I’m fairly sure I set it to encrypt, but only on the home partition… I didn’t know that would result in… well this. And I don’t think there was a warning about this either :frowning: But well, what’s done is done. Just wondering if I can fix that…

How would I do that on the Live system? :sweat_smile:


If all goes bad I might just nuke my Windows drive (and the games on it, RIP) to install there and move everything out of /home over later :confused: But I’d like to keep that as a last resort (never know when I might need a Windows install).

In the GUI, idk, right click on the lock or double click on it. Try stuff until it asks you for a password…

In a terminal, I don’t remember the specific command arguments off the top of my head. The command is cryptsetup though:


Output of lsblk would be helpful.

I believe cryptsetup luksOpen is what you want. You need to find the device name though.

1 Like

Yeah that’s what I tried, click just selects it, doubleclicking just opens the properties, right-click → mount is greyed out

Checked that earlier but didn’t see anything helpful:

[[email protected] ~]$ lsblk
NAME        MAJ:MIN RM   SIZE RO TYPE MOUNTPOINTS
loop0         7:0    0     2G  1 loop 
loop1         7:1    0     7G  1 loop 
├─live-rw   253:3    0     7G  0 dm   /
└─live-base 253:4    0     7G  1 dm   
loop2         7:2    0    32G  0 loop 
└─live-rw   253:3    0     7G  0 dm   /
sda           8:0    0 465.8G  0 disk 
├─sda1        8:1    0   200M  0 part 
├─sda2        8:2    0     1G  0 part 
└─sda3        8:3    0 464.6G  0 part 
sdb           8:16   1   7.3G  0 disk 
├─sdb1        8:17   1   2.1G  0 part /run/initramfs/live
├─sdb2        8:18   1   9.9M  0 part 
└─sdb3        8:19   1  20.8M  0 part 
zram0       252:0    0     8G  0 disk [SWAP]

Checked the man page to see if I can find anything non-destructive before using it. Tried cryptsetup status /dev/sda3 and the same with sda, both tell me Device not found :thinking:

I haven’t messed with luks in a while…

What’s in /dev/mapper?

[[email protected] ~]$ ls /dev/mapper -lah
total 0
drwxr-xr-x.  2 root root     100 Apr  3 14:17 .
drwxr-xr-x. 21 root root    4.4K Apr  3 14:17 ..
crw-------.  1 root root 10, 236 Apr  3  2022 control
lrwxrwxrwx.  1 root root       7 Apr  3 14:17 live-base -> ../dm-4
lrwxrwxrwx.  1 root root       7 Apr  3 14:17 live-rw -> ../dm-3

cryptsetup isLuks /dev/sda3

[[email protected] ~]$ cryptsetup isLuks /dev/sda3
Device /dev/sda3 does not exist or access denied.
[[email protected] ~]$ sudo !!
sudo cryptsetup isLuks /dev/sda3
[[email protected] ~]$ sudo cryptsetup isLuks /dev/sda3
[[email protected] ~]$

Seems to return nothing?

Sorry, what is the exit code of that command?

Also, try running: sudo lvscan -a; sudo pvs; sudo vgs; sudo lvs

[[email protected] ~]$ sudo cryptsetup isLuks /dev/sda3
[[email protected] ~]$ echo $?
1
[[email protected] ~]$ sudo lvscan -a; sudo pvs; sudo vgs; sudo lvs
  inactive          '/dev/fedora_localhost-live/root' [50.00 GiB] inherit
  inactive          '/dev/fedora_localhost-live/home' [406.66 GiB] inherit
  inactive          '/dev/fedora_localhost-live/swap' [7.90 GiB] inherit
  PV         VG                    Fmt  Attr PSize   PFree
  /dev/sda3  fedora_localhost-live lvm2 a--  464.56g    0 
  VG                    #PV #LV #SN Attr   VSize   VFree
  fedora_localhost-live   1   3   0 wz--n- 464.56g    0 
  LV   VG                    Attr       LSize   Pool Origin Data%  Meta%  Move Log Cpy%Sync Convert
  home fedora_localhost-live -wi------- 406.66g                                                    
  root fedora_localhost-live -wi-------  50.00g                                                    
  swap fedora_localhost-live -wi-------   7.90g

I also just noticed something. In the partition manager there’s the fedora_localhost-live on the left, which is actually the LVM partition on that drive. It tells me it’s mounted and so are the individual volumes:

But…

[[email protected] ~]$ ls -lah /run/media/liveuser/
total 0
drwxr-x---+ 2 root root 40 Apr  3 14:17 .
drwxr-xr-x. 3 root root 60 Apr  3 13:57 ..

I’m confused :thinking:

It looks like fedora live somehow inherited your pre-existing logical volumes which I don’t really understand.

Good news is that it looks like you did separate your home folder as intended.

I’ve got to go, but there are definitely others here who can help you through your lvm issues. I’m not very fresh with that stuff right now.

1 Like

Fedora probably detected the partition on the Windows drive and put it in /etc/fstab to automatically mount it, in case you want to use it. If a file system in fstab can’t be mounted, the system drops to single-user mode to let you sort it out. It doesn’t know which partitions are important, and which are not.

Yeah I did figure that, but it’s still in one partition even if it’s 2 volumes. And I’m not sure if that helps me install F36 over the original F33 volume :confused:

When using the “custom” mode in the installer, all the partitions on that drive also show up and I can sorta set up the mount points myself:

And as long as I leave “Reformat” unchecked that should leave the data on it untouched? But for some reason I can’t do btrfs on the root partition/volume (which was one of the reasons for the reinstall, just to play around with it):

image

Is btrfs not allowed on an LVM volume? Because by default new mounts points are created using btrfs when creating everything from scratch.

Yeah that’s what I was thinking although I am sure it was definitely not on automount (did show up in the Dolphin sidebar tho), so why it holds up there is a bit weird to me… not that it matters much though.