(TES: Skyrim) Can't absorb dragon souls


I have a bit of an issue, I recently started playing Skyrim again but I have encountered an issue. I can't absorb dragon souls. I recently got the Dragonborn DLC, and now I can't absorb the souls of the little bastards. I have tried the Unofficial Dragonborn Patch Mod, aswell as all other Unofficial Patch mods. But It did not help. I also tried disabling all of my mods. That did not help either. 

So anyone know what's up? The dragons just lie there, and It's quite the frustration. Especially becasue you have to be able to absorb souls to play the game. Also, the dragons look like this for some unexplainable reason. Not sure why. 

From my experience it can be a mod you installed that's interfereing with the files that let you absorb dragon souls. Or it could be a glitch cause as you progress through the dragonborn DLC you will kill dragons and Miraak will teleport towards you and steal your dragon souls. (This is not a spoiler btw)

I suspect your load order is in an inapropriate order, it should be like this.

  • 1.Skyrim.esm
  • 2.Update.esm
  • 3.Dawnguard.esm
  • 4.Hearthfires.esm
  • 5.Dragonborn.esm
  • 6.HighResTexturePack01.esp
  • 6.HighResTexturePack02.esp
  • 7.HighResTexturePack03.esp
  • 8.Unofficial Skyrim Patch.esp
  • 9.Unofficial Dawnguard Patch.esp
  • 10.Unofficial Hearthfire Patch.esp
  • 11.Unofficial Dragonborn Patch.esp
  • 12.Unofficial High Resolution Patch.esp



  • Source: