Terminal time-outs when Web page access is fine

Hey all
I have just started to have a look at some Android source again in a very long while however I notice that I have very consistent time outs with both Google and the androidsource domains within terminal. I can access these fine via Web browser and have these also routed outside my VPN on my opnsense box. I can also ping github.com

I am wondering if for git pulls whether it uses something slightly different than just the github.com domain?

I’ve tried to google what the github domains actually are however I just get results for adding a domain to github lol

Perhaps it would be best to run netstat -t while doing a git pull?

1 Like

Does "ssh -v [email protected]"work? Does “telnet 22” show “SSH-2.0-…” or nothing?

If neither of those work you might have hijacked DNS, try comparing lookups from https://dns.google/ with "dig " to check.

Other than that try a traceroute, see where you traffic is going. A timeout means your traffic is ether not making it to the remote end (outbound port blocking?), or the reply is getting lost somewhere (badly implemented firewall?).

I routed the device around the VPN entirely and repo sync worked first go.
Some subsequent reading seems to indicate that CDN’s can be a bit of a pain when your trying to route specific sites with VPN’s. I might try and get the whole range of IP’s from their meta file and format that into an alias to route all their IP’s rather than relying on the domain name.

Edit - So i think I have it working. I grabbed all the associated IP’s from the ‘git’ section within the https://api.github.com/meta and ran another repo sync which did not error out.