Swapped new AMD Ryzen 5900X Into Proxmox Server; No Longer See Full List of HBA-Connected Drives on Startup, But They're There in Proxmox. Problem?

I just installed a new Ryzen 5900X into an Asrock x570d4u-2L2T. I’ve got 2 LSI-9207-8i (IT mode) HBA controllers, each connected to 8 SAS2 SSDs.

With my previous processor, a Ryzen 7 3700X, I would see the LSI/Avago Boot Utility thing list off all 16 drives before continuing to boot.

With the 5900X, it lists off 8 (in other words, only sees a single HBA and the drives attached to it), and then allows the boot to continue.

Proxmox still sees all 16.

I’m still very new at this, but I’m guessing something changed in the way the server does its bootup process after installing the Ryzen 5900X, so that by the time the LSI utility triggers, it’s only able to detect one of the cards, and the second one comes in sometime before Proxmox fully boots.

The LSI cards are apparently both still rocking firmware from 2015, and I don’t know if I should bother upgrading them or not, at this point. I’m wary of messing with hardware I don’t fully understand when it’s otherwise working.

Is this a problem? Should I assume everything is fine if Proxmox can see all the drives? (Proxmox sees both cards via lspci, and sees all 16 drives and is able to interact with them in the web interface. I don’t have any storage pools set up yet, though, so I can’t really test them through Proxmox.)

I expect you updated your BIOS and lost your original settings when you installed this new CPU. The answer to your problems is in the BIOS, what it does at boot time to show add in cards. My RYZEN 7 2700 shows all the add in cards, many of them are bootable like the SFP+ and the intel NIC and the LSI HBA.

It’s probably not a problem because all your HBA does is present the SAS drives to the OS. Where as a RAID card would need to see the drives itself so as to know what assembled array to present to the OS.

1 Like

Thanks! That fits with what I’ve experienced.

Proxmox sees them all quite happily, so I won’t worry about this anymore.

At some point I’ll likely update the firmware on the cards, as they’re both running firmware from 2015. That might make them show up at boot, but if it doesn’t, I don’t care.

This CPU in combination with this motherboard has been a pain. I had to reseat the CPU because it came out of the socket when I tried to rotate the cooler to fix an airflow issue, and now the BIOS (and thus, the rest of the server) isn’t seeing anything in bank B. So, half my RAM is not showing up.

I’ve reset the BIOS and even pulled the CMOS battery to no effect.

Eeeew that’s frustrating. I’d re-seat the CPU. Fortunately AM4 motherboards are cheap. I have a 5900X in my desktop on an MSi X470 with 32GB RAM. I did have a bit of tinkering before it worked right. My RAM is 3600 which I’m running at 3200.