Return to Level1Techs.com

Supermicro X10DRG-Q Won't Boot To Intel 750 PCIe NVME

helpdesk
uefi

#1

I’m trying to get this Supermicro board to boot to an Intel 750 PCIe NVME drive. Windows installs to it fine, but it just won’t show up as a boot option. It’s as if the motherboard doesn’t support it, but it’s supposed to and apparently, someone else made it work.

At this point, I have all of the PCIE slots set to EFI and only UEFI boot options, although I’ve tried a lot of combinations.

I’ve sunk a few hours into this. Very frustrating. I might just reach out to Supermicro, but trying to avoid that as I can only work on it outside of normal business hours.


#2

Their is no m.2 port on the board right? So you are using one of them expansion cards?


#3

Yes.

I’m wondering if there’s a way to use a boot loader on a satadom to work around the issue. I almost never deal with Windows, so I don’t know how that would work.


#4

You could do that, but you shouldn’t need to.

Maybe you want to configure Boot options to show both, legacy and uefi options jus in case.

Did you enable PCI Option Roms?
I can’t really remember how those are named, but i can look it up soon.


#5

Tried that.

These are all set to EFI.