Strange Ryzen 3700x mem/hardware errors

I just bought a new 3700x based system and been having all kinds of strange stability problems.

I’ve since done some memtest86 runs and each of the 4 16GB sticks test fine and each slot seems to test fine, but if all four slots are populated memtest86 will show errors within 5 to 10 minutes. I’ve tried bumping the DDR voltage but it didn’t fix the problem.

Hw list:
CPU: Ryzen 3700x
MB: Gigabyte Aorus x570 Pro WIFI
RAM: 4x Corsair 3200mhz 16GB (on the MB’s men support list)

Any help would be appreciated.

Append: my best guess is when xmp is enabled some setting or another is wrong and causes memory instability. Or maybe the hardware itself doesn’t want to run at 3200mhz.

It might be a slot malfunction. Have you tried each DIMM slot separately?

NM, I see that you have tried each slot.

Does it fail at stock speed (2133MHz/2400MHz?)?

So far at 2+ hours in no. It’s doing ok at stock speeds. Which I think is 2133. I’ll let it go longer though.

I did notice the uefi didn’t seem to set the right ddr voltage and corrected that (to 1.35v) as well as tried slightly higher memory and soc voltages. So far nothing has seemed to help.

I’m tempted to try re seating the CPU but no idea if that could be it. I had this machine assembled and supposedly tested so I didn’t have to worry about this kind of stuff this time around. Just my luck.

1 Like

have tried loosening the timings when you run at 3200mhz?

And what f-clock do you run?

A friend of mine asked me about advice on his software crashes.

I sent him a longer list of suggestions

The List

WinKey + Pause > Device Manager
There should not be any yellow warning symbols!

  • Completly reinstall GPU drivers
  • Reinstall or update Chipset drivers

Misc things

  • Remove all other PCIe devices (WLan, Soundcards, etc.)
  • Update BIOS (on R 3000 to “ABBA”, on 1000 and 2000 DON’T, also: Leave the BIOS on MSI boards alone, they got some hefty bugs)
  • Windows powerplan -> Ryzen Balanced

Exotiv solutions

  • Clear CMOS (consult mobo manual, place over, count to 3 and place it back)
    -> On MSI and Gigabyte, not having the jumper in the system at all can help (yes, really)
  • Change the positions of your RAM sticks, what was in slot A2 goes to B2 and vice versa
  • Just boot with one stick of RAM
  • CMD as Administrator chkdsk c: /f /r /x
  • In BIOS, set memory voltage (VDDR or VDimm) to 1.35 V

Guess what, it was missing chipset drivers.

1 Like

What is the exact memory parts number?

I haven’t messed with anything other than enabling XMP and the memory/soc voltage. The timings automatically loosen or /should/ anyhow.

My issue rears its head In windows, linux and memtest86. I appreciate the tips though. I have tried each stick individually and for short memtest runs they tested fine. At least they lasted longer than when all 4 slots were populated.

CMK32GX4M2B3200C16 on all 4. Two 32GB kits.


I just tried two sticks from the same kit in the primary A2 and B2 slots and that also fails.

I also noticed that the UEFI is properly setting the voltage but it isn’t changing the main column when it does so, i have to look to the right hand side where it shows the current actual voltages. Figured when I changed the profile it would update the column of data to the right of the editable column.

1 Like

yes, they “SHOULD” loosen as the XMP is enabled, but i always find XMP to not be fully optimal, i would try dropping timings one sku down, and see if that fixes the problem, if it does, try turning speed down to 3000mhz and tighten timings back up to where they were

Just gave that a shot. dropped the primary timings down one notch. Got errors after about 5 minutes.

Also, this memory was guaranteed to run at 3200mhz at the given timings. The kit is also on the motherboard’s memory support list. It /should/ work. If I can’t get it to work at its rated speed I’ll just take it back. There’s no reason to accept less than what you were guaranteed at purchase time. That said, I’d still like to see if I can get it to work.

IIRC, the “official” supported speed for 4 x Dual Ranked dimms with Ryzen 3000 is 2667. Although “safe” speeds typically fall within the range of 2933 - 3600 using that configuration (4xDR). The 3200 MT/s you are attempting “should” be doable but, it comes down to the memory controller limitations of the CPU, with those limitations becoming more apparent when populating all four dimm slots.
Noting that you mentioned running at default 2133 appears to be stable could be indicative of the limitations described above or, random coincidence (memory tuning is not an exact science after all and many variables exist, even across identical hardware configurations).

You might try simply reducing the speed (use settings from XMP profile but alter the speed say to 2933 as a start if stable then try raising to the next step retest etc until find the max the mem is stable at . Obviously try lowering to to 2667 of not stable at 2933.

You could try entering in the timings matching XMP profile manually. I myself have experienced instances of “odd” behavior when just enabling XMP profile that seemingly were resolved by entering timing manually.

Couple other thoughts - set your DRAM voltage manually no matter. Perhaps I am just a crazy koot but, real or not, it seems to have an effect in my experiences.

Also worth noting is that Corsair and others are not always consistent with ICs used on mem kits even with the same model. You need to check the model and revision number etc. I mention this only because the XMP profile used on the bios may be good for a set of ram of that model but your exact same model may be using different ICs.
Definitely get - Thaiphoon burner and run the report for your modules - you want to determine exactly what ICs are used on your mem kit(s). This is important for determining values to apply.

Perhaps consider Ryzen Dram calculator (1usmus), even if only to get ideas for starting point values to try based on your mem.

unfortunately that tends to happen with “rated” speeds on ryzen, ive had similiar issues on my 3900x, in my case i had to lower the f-clock a tiny bit, and play with the timings for a loooong time to get it stable at 3600mhz.

Then i got fed up with it, and spent the extra cash and bought some other ram, which booted straight up at 4000mhz, i think its a lucky draw because of the memcontroller setup on Ryzen!

But if i were you, i would probably scrap XMP, and configure it manually! is “clockdown” enabled on you ram?

The mem QVL for your board lists your memory at a native speed of 2133.

It’s down to more than the actual mem kit - the CPU mem controller plays a major role here as well. I know it sounds crappy to hear “it’s the silicon lottery” but, it often is more true than not. Don’t give up - as it has been said before - there is no exact science to mem tuning. Some configurations take a little more trial and error to get working.

You have several really good allies in here willing to as much as they can -

I will give that all a shot.

I have been testing with just a single matched pair of sticks. And setting the primary memory timings manually. Same errors within 5-10 minutes regardless of settings. I have tried setting memory voltage manually at times though not currently as it didn’t seem to make a difference. I’ll try it again.

Looking at the two kits, the model/part numbers are the same, and the serial numbers are /very/ close. Within say 8 iirc.

I have been setting the primary timings manually. So far no real difference. Errors in memtest within 5-10 minutes.

I think I’ve tried with clockdown set to auto, enabled and disabled at this point. But I can’t guarantee that.

Both corsair and Gigabyte gave me a guarantee this would work. Gigabyte’s memory support list explicitly listed these for 4 slot usage iirc. So perhaps its a flakey kit tht can’t quite do what it’s supposed to, I dunno.

I know ryzen is finicky, but between the guarantees from Corsair, Gigabyte and the place I bought this machine from having assembled and I presume tested it before shipping it given I got an extended warranty and it took them a week to assemble it… It aught to work with minimal fuss. perhaps I’m being “entitled”.

So far though a test on the second kit with the loosened timings lasted longer… but JUST as I was typing this threw an error at about the 10min mark. Funny how its generally going to fail at or before 10 minutes.

It also has XMP checked with the lower timings.

Return it. It doesn’t do what was advertised.


Believe me when I say I appreciate all the help so far!

I’d really like to see if I can get this to work. But it is my primary workstation and need it to be stable. I can only spend so much time tinkering with it.

I apparently missed this too earlier - If you bought this system and had it built assembled / configured by a third party - You should not be responsible for getting to work as “Advertised” Return it to the builder for them to resolve.

1 Like

I’ll actually have to see what they say about it as it isn’t a typical OEM system builder, rather they provide a system builder and I configured it. So they could just claim it’s my fault for the choice of ram. who knows. I’ll call them on monday and see what they say. I did try and do some research about the motherboard and memory kit prior to making my selections. people did have good experiences with the particular memory kit.

Actually just checked the specific wording in the assembly/warranty option I purchased, it says a lot of things that I don’t think they lived up to. so I think I have a lot of wiggle room there. Cool. The text explicitly says they will configure and test everything to work properly, including verifying part selection is optimal and updating the bios to most recent stable bios with no issues. turns out it was on the original release bios that I seem to recall could have had boot issues, but didn’t for me at least. So there was a lot to be desired with this build I think.

I still like to tinker though :grin:

So far 2933 is working better than any other changes. Fun. 12min and counting.

1 Like

Really sounds like they didn’t do their homework. Just because of that I would return it and demand my money back. Like @Delta9K said, you shouldn’t have to deal with that. That is what you paid for.

Yeah, they deffinitely should have done more testing/work before releasing it. I don’t mind if they just make it work with a different kit or kits or maybe a less finicky cpu etc.