Strange problem that happens on interval

I have 5 PC in the network, with several folders share. 4 of them are Linux based, 1 is Windows.

We store some video presentations on them that we play from the network with VLC player.

So, the problem is that from my personal one, Manjaro, every HH:00, HH:20 and HH:40, the playback pauses for 3-10 seconds and then resumes.

Also, and this is strange, the problem disappeared few days ago, but today we had a power outage and it started again.

Any ideas where to look? Logs? Scheduled tasks? Background services?

Operating System: Manjaro Linux
KDE Plasma Version: 5.20.5
KDE Frameworks Version: 5.78.0
Qt Version: 5.15.2
Kernel Version: 5.10.7-3-MANJARO
OS Type: 64-bit
Processors: 24 Ă— AMD Ryzen 9 3900X 12-Core Processor
Memory: 31.4 GiB of RAM
Graphics Processor: Radeon RX 5500 XT

If share is on windows:
-Check power settings for network adapter in Device Manager and Power Settings
-Check advanced power settings for network adapter and USB Hubs(is usb storage) in Device Manager, turn off allow device to to be turned off on power

Wireshark/nmap the network and try have it capture all packets which trying to recreate to time out.

Power settings, timeouts, cache size on adapters and sleep settings can be the culprit, may need to clear your router /switch cache (if possible). thank you for your suggestions. No, my shares are both on Linux. One on Manjaro XFCE, the other on Qnap NAS with a Qnap Linux version. The only Windows system acts only as client.
I had the problem with NAS originally, I though it was something on the NAS, but while troubleshooting, I tried using another Manjaro share, and happens there too.

Power settings are disabled on all machines.

I am focused on some short of services as it happens on exact times, not just randomly.

Could check the cron jobs/logs

Tin foil hat moment:
-Power supply board delivery for NAS maybe damaged
-Drives are in trouble, not enough power or taking more power to spin up looks like I didn’t explain correct…

Client: My PC
Server: NAS
Problem: video playback freezes for 3-10 seconds every HH:00, HH:20, HH:40

Client: Any other PC
Server: NAS
Problem: cannot replicate

Client: My PC
Server: any other Linux PC
Problem: video playback freezes for 3-10 seconds every HH:00, HH:20, HH:40

Therefore, the problem is on my PC, not the servers.
Also the routing path between my PC and NAS is different from my PC and other PC, so it is not a router/switch problem.

Could be that the Memory of system or Graphics card and/or graphics card.
Try Driver/Firmware refresh or physical port change with a power cycle.

Wendel referral maybe needed. after some more troubleshooting yesterday, I found out it happens only when playing the videos directly from a network share.
What I did was to start playing a video at 22:15 last night, at 22:20 froze for about 5 seconds, and then resumed.
Then I copied locally the exact same video, no issues or freezing while copying, and started playback at 22:35.
Normally, at 22:40 would freeze for few seconds, but it didn’t. I also tried at 22:55 and again it didn’t freeze on 23:00.

I assume that it is NIC related and no network in general.

I would look at NIC Cache /buffer / Timeout/ connectivity dropouts etc… it may turn out the hardware may have dust in the plug socket.

htop in a terminal when monitoring the dropout, process/memory spikes and lulls can show the affected systems.

I am not sure what happened, but the problem disappeared after some updates that happen in the last couple of days. Same kernel though.
So, it should be some sort of service that caused it, since I didn’t make any changes to my system.

The problem re-appeared again… And this time I noticed that this is NOT network related, as it happens on the same intervals (HH:00, HH:20, HH:40) even when I am using local disk (SSD or RAID)
I first noticed it when I tried to save an image from web with Firefox, and the folder window came up empty with the “Save” button disabled. After 3-4 seconds it resumed. Then it happened few more times so I noticed the time and all of the cases were in the certain times.

This removes any network issues from the equation…

Any advise?

You might try running htop at the same time, to see if another app causing resource spikes, and/or journalctl -r and scroll back to a time when it slowed, but that gives a load on info.
There are options in joirnalctl to differentiate between like error and stuff, but the slowdowns might not be an error they could instead be badly scheduled backups etc.

1 Like

My Timeshift is scheduled to run every day at 9pm. No other backups running.
I do have a software RAID (mirror) though. Can this be doing some maintenance?

To be fair, neither of us knows what it is. But running regularly every 20 mins sounds like it is one app doing Something on a schedule.

Disk Scheduling could be many things, quick diagnosis would need:
-Change Drives connection to motherboard
-Check power to the drives, draw could exceed supply

check all schedules as Trooper_ish said

20 mins reminds me of trim operations not configured/running.
check your drive s firmware and make sure the build your using has been updated to a stable driver

Thank you for the input.
However I am a bit confused…
I have the same problem with all drives (HDD, SSD, M.2, network shares). Can trim be the issue? Or the firmware?
Also it happened months ago and happens again after many kernel/driver updates.

you may have gotten a bad mobo or some pathway is defective