Steam Problems on Ubuntu

When I try to run steam it says I am missing Have searched the interwebs and tried many "fixes" but still no luck. Ubuntu is on a HP envy m6 laptop with an amd a10 apu. Thanks for any help.

In terminal sudo apt-get install libgl1-mesa-glx libgl1-mesa-dev forum I found solution

and This forum

I am not on Ubuntu or linux at the moment, been meaning to do some Steam work on my Ubuntu laptop, check those forums for details on what that problem was that they cam into and go from there. I cannot say for certain that this will work.

Remember to let us know if this fixed the issue.

If you can install a program/software through command line then do that, you will download any dependencies with it as well (few exceptions).


sudo apt-get install steam

I have tried this before and had a problem with that working correctly. Thanks for the reply, I am working on getting that problem fixed also, which I may have to do before I can get steam to run.

Hallelujah it worked, I'm a n00b with linux but you better believe I will use the terminal to download everything from now on ha. Thanks for your help. Problem Resolved.

Your welcome and glad to help!

Yeah Terminal is ALWAYS best. Plus if you screw up you can always purge the application and start from scratch.

1 Like

I thought I was the only one who still had the "Google package name, install from terminal" way of doing things :P I suppose I could use Aptitude but I just love apt-get