Return to Level1Techs.com

Steam Play + Threadripper + Ubuntu sanity check

#1

I recently built a Ryzen 2700X + Aorus Gaming 5 system running Ubuntu 18.10 + Steam. It runs fine. It’s held back a little by an old GTX 1050ti card but it otherwise runs really well.

But now I want to build my system which is centered around a X399 Taichi + TR4 2920X system running Ubuntu (likely 19.x).

I’ve been reading that Steam Play can be fiddly on cpu’s with more than 8 cores and crash on the splash screen. I believe this issue affects certain games but not all.

Anyhow, I’m having a hard time finding any details about these problems specifically affecting Ubuntu (or linux in general). In fact I can’t find any, everything I’ve been reading about Steam crashing on Threadripper has been related to Windows 10 + TR + Steam.

Is anyone out there running Ubuntu with Steam Play + TR? What are the challenges and workarounds you’ve had to deal with? This post makes it seem like it could be a pita.

Any info is helpful, thanks.

0 Likes

#2

If you really need more than eight cores, I would wait for Ryzen 3000 series. Not just because of steam issues but because it will be way more mainstream and therefor have way better support from all sides.

0 Likes

#3

I have had zero issues with my 1950X and Steam Play. However I run Kubuntu. Ubuntu itself was full of issues and just didn’t work well with my system for some reason. Make sure you use the NVidia close sourced driver. I’ve played several under steam play different games and they all work great. I have a library of over 800 games, though I’ve only tried a handful of them.

Microsoft is in trouble. All it’s going to take is a vendor to produce a polished Linux distribution (something that “just works”) and they’ll leak users like nothing else. Gaming was the last straw that kept me from moving over. Now it’s solved.

1 Like