Star Wars Battlefront is giving me trouble in my Windows VM with PCI-Passthrough

I have been using my Windows VM with PCI-passthrough for a while now and I have had no problems with it until I got Star Wars Battlefront. When I try to open the game, the VM freees for a few seconds and the reboots. It looks like Windows is trying to bluescreen because there are new memory dumps when it comes back up. They all say the following when I analyze them with whocrashed.

On Sun 12/27/2015 7:30:57 PM GMT your computer crashed crash dump file: C:\Windows\Minidump\122715-8609-01.dmp This was probably caused by the following module: ntkrnlmp.exe (nt!KeBugCheckEx+0x0) Bugcheck code: 0x3B (0xC0000096, 0xFFFFF8033B944CAC, 0xFFFFD000217260D0, 0x0) Error: SYSTEM_SERVICE_EXCEPTION Bug check description: This indicates that an exception happened while executing a routine that transitions from non-privileged code to privileged code. This appears to be a typical software driver bug and is not likely to be caused by a hardware problem. The crash took place in the Windows kernel. Possibly this problem is caused by another driver that cannot be identified at this time.

To me, it looks like a driver issue, but I don't know that much about Windows. I tried all of the fixes from EA's help, but none of them did anything. I updated to the latest nvidia drivers, but that didn't help either.

The system has an intel 17-4790k cpu and 16GB of ram. The vm has 12GB of allocated ram and a gtx 750ti given to it via PCI-passthrough. Any help is appreciated!

I tried redownloading the game again and this time when it crashed and the system came back up, The virtual drive where the game was stored looked completely empty, as if I had just created it. Maybe Windows got creative with the partition table or something? I've actually used Linux pretty much all of my life. Windows just confuses me sometimes. Guess I have to download the game again now.

It's no consolation but on my setup everything I tried to run game-wise ran perfectly until Fall Out 4, with FO4 I had the exact same issue on my all AMD system, like you I believe it was related to drivers and in my case it looks like it was the video drivers, I'm not sure I had the same error but the behavior was the same until I updated the drivers to the latest Crimson drivers (I know your running Nvidia)

One thing that is different on my system is that my KVM doesn't use a virtual drive I gave it a entire physical hard drive for the guest to use, I don't think the specs are much different but my system has 32g of RAM and I give the KVM 16g of that along with 4 cores of my 8370, like I said nothing ever caused this type of instability in the guest until FO4 and with the latest drivers it has solved the issue like 90% of the time (the game is playable and I've logged a few hundred hours in it now)

You might try using a program like DDU to completely uninstall the old video driver as it seems to do a much better job at making sure all of it gets removed then try reinstalling the latest drivers again.

I just ran DDU and reinstalled the nvidia drivers. I would like to test it out but I'm still waiting for the game to download.

Good luck.....

I might also mention that I run Win 7 ultimate as the guest system, and a vanilla install of the OS would run most all games but a few required me to install SP1 to even get the games to load, not a big deal, so with FO4 before I had the display driver issue I had to turn on the updates and let it update the system to get FO4 to even load without a failure, this allowed me to be able to load the game up but after anywhere from a few minuets to a couple hours the game would crash randomly most times just back to the desktop the KVM remained stable.

After installing the new Crimson software to try to solve the random crashes it got the point you are at with blue screens and memory dumps completely killing the KVM and at times crashing vert-manager in the host, so I updated the host system to the latest stable version (Fedora 22) and it changed nothing with the guest, turned on the Windows update and let it install all the updates till it started nagging me about Win X then turned them back off and installed Spybot anti-beacon to get rid of the telemetry BS, this actually made somewhat of a difference in the frequency of the crashes but it would still crash about half of the time.

Finally AMD updated the video drivers last week and the problem has for the most part gone completely away, I have had the game crash a couple times in 60-80 hrs of play time but nothing like it was, and the game seems much more stable than it has been, I switched over from the original release of FO4 to the beta stream through the course of trying to figure out if it was the game, OS, or drivers and have never switched back so I think a little instability could be caused by the beta but not really sure, of all the things I tried the display drivers seemed to be the thing that had the biggest effect of making the game stable and playable on my system, of course your mileage might be

Like I said good luck and let us know what happens.

Same thing happened with the drivers reinstalled. I'm going to try the latest beta drivers next.
No beta drivers that I could find. I am running on the latest drivers.

I fixed it by running this as root.
echo 1 > /sys/module/kvm/parameters/ignore_msrs
The tutorial looks I just have to get the game to actually find me a match :( I've been waiting for hours now.

1 Like