SSTP VPN on unbuntu budgie 20.04 LTS not working

Hi everyone, can you help a linux noob!

So i have played with the idea of switching to Linux as my primary OS many times and every time there is some huge thing that stops me. Well this time I’m determined to do it for my work laptop, i looked into it and i can do almost everything i need to with a web browser and a decent RDP client there is only one application that “needs” windows, but i can get around that with the RDP client for the most part (i may look at setting it up as a remoteapp, i have read some of the RDP clients for Linux support them)

So far i have tried a few different distros, started with elementary OS got the vpn working and most other things but wasn’t really into it.
Then tried POP OS but there where some things about it that got on my nerves and now I’m trying Ubuntu Budgie

Got everything going just fine except for the VPN which seems strange as it worked fine on elementary OS and i thought they are both based on ubuntu?

Did some looking into it and i keep coming across that there is a bug in 20.04 that stops SSTP from working, i can setup the connection but then when i try to connect the switch icon will switch “on” then immediately turn “off” again.

I know it should work as i had it working just fine in elementary OS.

Does anyone have any suggestions or a known work around, or do i need to go back to elementary OS?

Any help greatly appreciated.

Regarding the difference between Ubuntu and elementary OS:

elementary OS 5.1.4 was an update to version 5.1 (Hera) released in April, 2020, and only the 64-bit version is available for elementary OS 5.1.4. This update release was based on Ubuntu 18.04.3 LTS


Regarding the SSTP issue, perhaps this might be of some service.

Thanks, i didn’t notice that elementary OS was on 18.04 not 20.04 so that explains why it works there and supports what i have been reading that it is a bug in 20.04 and that the packages have not been updated yet.

I have seen that forum post you linked during my own research but i don’t get what they are doing in that last post that supposedly got it working? Are they making the ppa return an older version of network-manager-sstp and network-manager-sstp-gnome?

I’m thinking that i might just go back to 18.04 for now until things get updated

So i decided to give Pop!_OS another go and downloaded the 19.10 version and installed it, so far i have managed to get everything working and have a functioning VPN connection, so i am going to roll with this for now and i see how i go.

The Ask Ubuntu answer says that that person didn’t need that package for that connection. I have never dealt with virtual private networks of any kind, so I’m just shooting in the dark here.