Return to Level1Techs.com

SSD issue

#1

Hi, I tried to secure erase an SSD, and now I have an attractive paperweight.
I tried a couple of things but can’t revive it.
Any suggestions before RMA would be appreciated.

Not at PC at the mo, but according to hdparm -I it is not frozen, but is locked.
Pc won’t boot with it connected.
Laptop will boot, but asks for a user password to unlock the SSD before it will load bios.
I didn’t set a password for the drive.
I tried sedition-CLI, but it doesn’t have it listed as an opal drive, and refuses to access it. Any other suggestions?

0 Likes

#2

Oh, and it is a Samsung 850 pro.
I tried hdparm —security-disable with Master password ttttt(32 t’s In a row) and separately with user password NULL as I hadn’t set one, but no dice.
I get error message/report 70 04 00 00 00 (maybe a few 00’s following )

0 Likes

#3

Just an idea, but if you connect it to a Windows PC as a secondary drive and run Samsung’s Magician software then just maybe it could do something with the drive.

2 Likes

#4

see if this does anything for you

1 Like

#5

Thanks for the idea.
When I attached it to a computer running magician, I refreshed, it did appear in the list of drives in magician, but listed it as an unsupported drive

0 Likes

#6

Huh, I didn’t try to set a new master password. That might just do the trick… 2 hours of my shift left, then gonna try that

0 Likes

#8

Thanks, I was hoping I could do something to unlock the drive without having to send it off, but am glad I went for a pro with this one, most of the drives I get are non pro(cheap level) and don’t have the same warranty period, so I know I can RMA it if needed

1 Like

#9

Okay, I think I got it…
TL:DR xxxx is the password I needed, literally four lowercase x’s

I used Gnome Disk (gnome-disks) to issue the secure erase.
I’m sure it reported sucess, but didn’t need the drive again that sesion, so hadn’t checked.
Next time I went to the computer, it was in locked status
I didn’t twig that the drive was still in locked status, thinking it was still doing a secure erase.

Do do a secure erase, one must issue a password.
Gnome disks kindly did so (on the qt, I dodn’t know, not that I need to know)
but the operation must have failed, leaving the drive in a locked state, with the password still as it had been issued at the start of the operation.

So off I went looking throught the internet till I came across this tonight:

and the answer provided by the user Jestem Łukasz seems to have done the trick.
He worked out that Gnome disks is the front end/gui for udisks, and that the password set is as mentioned above.

Now I’m gonna re-boot and see if it sticks… fingers crossed :crossed_fingers:

4 Likes