Sound Blaster Z no sound on Linux


So I’ve read online before purchasing the Creative Sound Blaster Z that previous issues with Linux were fixed and that sound should work out of the box.
However I’m currently running Fedora 33 with kernel 5.8 and no such luck. I can select the source in the Gnome settings, as well as in Pulse Audio volume control but no audio comes out. I also tried messing with alsamixer but with no luck.

Anyone has experience with this? I require a sound card mainly to record from a turntable when I digitize my records and to benefit from better sound quality. I haven’t tested my new B550 MoBo Min input but my previous build had too much noise in the mic in and as such I decided I needed a sound card which it greatly reduced the noise in recordings.
I probably should have not bough Creative as they are no Linux friendly, anyone with experience in recording turntables can suggest alternatives? Do USB sound cards have good Mic in connections and DACs?


Are you using the correct output? Are the channels unmutted?

Also make sure you are installing the non-free firmware. RedHat does not usually provide this out of the box due to legal reasons.

1 Like

Thanks!! It was the alsa-firmware!
Now the sound output works just fine. Much appreciated!

1 Like

No worries. I am glad that it worked for you and you marked as solution for future persons.

1 Like