Something up with the Broadcom HBA 9400 line? Having standby S3 issues (previously working fine for years), models no longer listed on Broadcom's support website

Hi,

While I know that the HBAs formerly known as LSI/AVAGO now Broadcom have been the industry standard for over a decade I seem to bump into weird stuff with them. I have been using two units of the HBA 9400-8i8e for homelab use for two years and of course, just when I was finalizing a build I’m now experiencing new issues:

  • The HBA and its driver supports standby S3 mode of the host system; had been working fine for almost four years.

  • New issue: After a power cycle the system is running fine and can enter S3 mode (and wake up again), initiate a reboot or a shutdown via the operating system (tested Windows 10 x64 21H2 and Linux).

BUT: After the first use of the S3 mode and successfully waking up, the system crashes with a BSOD when trying to enter S3 again or do a reboot or a shutdown, the system is in the process of rebooting/shutting down for a few minutes, then also crashes with a BSOD.

Yes, the categories on the screenshot show the correct selection of parameters to get to the HBA 9400 8i8e downloads, at least it had been in the past.

When selecting “All” in the last two drop-down selections you can still see the various files for the 9400 models (P22 are the latest releases, tried it out but didn’t change a thing)

  • I then tried the second HBA 9400-8i8e I have and it’s behaving exactly the same. If I remove the HBA the systems work completely fine again.

I previously had very bad experiences with Broadcom’s customer support, so I wanted to check here if anyone with more ties to the industry knows if something’s wrong (just like with the Intel P4500 SSDs, for example)

Regards,
aBavarian Normie-Pleb

If I understood correctly this was working but now is having a problem. Or 2 years later you’re just starting to try/test S3 mode?

If everything was working and you’ve tried two different cards I’d tend to not think it’s the card specifically but something else in the environment like updates to drivers or the OS itself.

You could try booting from a thumb drive or USB3 SSD starting with a build you know was working previously without doing updates. If that works try updating the OS on the boot disk to see if it breaks. Same with any drivers. If the OS and all drivers are updated and the card works correctly you narrowed down a lot and can focus on config changes or other software.

But for something like this if previously working would be trying to think if any bios changes were made recently. I’d even consider printing out each page in the bios for reference and resetting it to default and trying again.