[Solved] WLAN and Linux Mint/Samba causing W7 extreme slow boot issue

Ran into a unique issue tonight that was interesting, which is now fixed, but I thought I'd pass it along, just in case someone else ever feels the pain while learning Linux. I dual boot a Linux Mint/Win 10 laptop, while I have my main desktop workstation on Win 7. While doing file cleanup on my W7 workstation to get it ready for its weekly offline image backup, I rebooted and the W7 workstation took around 6 minutes to boot.

Uh oh, I said. I rebooted again, same thing, so I started pulling startup items offline and rebooted each time, hoping it would show me some improvement. No luck there. Well, I was getting ready to start disconnecting my external drives and other internal storage drives when I remembered trying to connect through my WLAN to my Win 7 workstation the previous evening and Samba/Mint refused to connect to the W7 machine. It wasn't important at the time, so I forgot about it.

Since I am still a relative noob in the world of Linux, I began wondering if it could be causing a boot issue on my W7 workstation, so I went and shut down my laptop, then rebooted my workstation....and zip!, it fired right up to the desktop. Whew...

Sometimes, I don't think I will ever reach a point where I am not scratching my head, trying to figure these things out...

Shouldn't have any impact, Only change linux does on your system is write a small program in the boot sectors of your system so you can dual boot.
Anything else changed is done completely seperate partitions than the windows system e.g. seperate partition.
Im guessing your stuck for those 6 minutes with the windows 7 logo sparkling infront of you right?

To maybe clarify a bit I run Linux almost exclusively now on my W10/Mint dual boot-laptop and was trying to access a shared folder on my separate Win 7 Desktop workstation, and that workstation was the machine having issues.

It always made it through the boot logo just fine. When it hit the blue Welcome screen all drive activity stopped for about 3 minutes there, then it resumed and when it began loading the Desktop, as soon as the Networking icon appeared, all disk activity ceased again for another 3 minutes and then booted the rest of the way without issue.

Once fully booted, no slowdowns or any other issue was detectable.

My desktop workstation stays up 24/7 except for severe storms or when I reboot to have a fresh run at imaging the drives.

I might have thought this was something other than the shared folder / network connection between Samba/Linux and Windows, but I probably rebooted about 8 or 9 times, before shutting down my laptop and rebooting my desktop workstation again, which seems to have been what resolved the issue, as everything works perfectly fine now.

Still scratching my head, but it just reminds me that I don't know as much as I think I do. :-)

Is the laptop / workstation hooked up to a domain? We had a similar issue on our domain here because we at the time had a network issue and that made the workstations timeout to the login server; which yeilded high login times.

It seems I am humiliated once again. :-)

My W7 workstation just bogged down again, but I've got my Linux system off. I now suspect an external storage drive is starting to go bad. After a reboot, the AutoPlay dialog box popped for that drive, so I ran some diagnostics and it failed a S.M.A.R.T. test, so I'm now leaning in that direction. A bad external drive device does seem to make more sense, as that would be about the time the USB drivers were being loaded in the boot process, rather than networking.

Since Linux apparently had nothing to do with this issue, I guess we should abandon this thread, while I go do more homework to get it sorted out.


You could mark it [Solved] in thte title. Incase people from the future stumble upon the thread.