Return to Level1Techs.com

[Solved] Trying to permanently enable my 10Gb NIC in TrueNAS

EDIT: /boot/loader.conf had to be edited and if_atlantic_load=“YES” had to be added to the file.

After spending a lot of time trying to get my Asus XG-C100C working, I found out the drivers are already in the system. The catch is that I need to type “kldload if_atlantic.ko” for it to load and make my NIC visible in the webGUI. However, it doesn’t stick. If I reboot, it is gone again.

I’m sure there has to be a way to make it permanent?

1 Like

I have no experience with this, but Google turned up a reddit post that looks like it may have useful info:
www.reddit.com/r/freenas/comments/glu5fl/freenas_included_drivers_how_do_i_enable/

Good luck.

Okay, so I have to set this up in the Tunables menu in the webGUI. I have tried a few combinations now without success. How do I fill in “kldload if_atlantic.ko” correct in the interface? It requests a variable, value and type.

I ended up finding my answer on a Japanese website.

The webGUI thing just did not work for me.

/boot/loader.conf had to be edited and if_atlantic_load=“YES” had to be added to the file. Looks like TrueNAS does not override this file and the NIC show up after a reboot!

4 Likes

Nice, thanks for reporting! Now we can all benefit from your journey :slight_smile:

1 Like

Congratulations! And thanks for sharing with the rest of us.

The best solution would be to get a NIC that is supported out of the box, like one that is Intel-based (or mentioned as supported in the docs.)

However, this Aquantia-based card from Asus is the most readily available card for me, and also what I had on hand.

Maybe someone else also end up using this card and can find this info useful.

I thought I’d follow up on this thread.

Performed a system update on my installation, and that wiped the config.

It sticks on reboots, but not system updates. Adding it back to the config file brought the NIC up and running again and verified it still persists after reboot.

2 Likes

Hey yall, also trying to get my Asus XG-C100C working in TrueNAS (12.0.U.2). Ive tried both the GUI setting via Tunables and manually editing /boot/loader.conf and neither of these get my NIC to appear in network interfaces. I booted ubuntu from USB and it pops right up so its not a hardware issue Any ideas?