[SOLVED] Transfer file onto crypted Android phone

Hello fellow members today I have a simple question for you that I can’t seem to answer on my own: I got myself I brand new Android phone and it comes crypted by default. I wanted to connect it to my pc and copy things back and forth from it but, when I connected it nothing shows up. Am I doing something wrong? How do I get around this without removing encryption? Do I need drivers (doesen’t look like it really)? Thanks

Helps to know what the phone is and the OS.

You can probably move files from a computer by installing an application on your phone that can access network shares on computers, then using that to copy files over to the phone. I personally use “File Expert HD” - has many functions but I only use the SMB share access.

Edit: Obviously you’d need to use WiFi (or VPN over Internet) to access your home network.

1 Like

It’s clearly written “Android” and the phone it’s a Moto X4 with Android 7.1.1

Thats what I meant. And as for OS I meant like… Linux, windows (#), OSX…?

Yeah, this might be the solution to my problem but I’d like to see what others come up with. I want to dig deeper in this. Thanks for the answer

This might be over-simplified, but on my own encrypted Android I have to have the screen unlocked and the correct USB mode selected in order to transfer anything to and from the phone…


Yeah, I got Android 6 Encrypted on my phone and all it needs is for it to be set to USB transfer mode after being plugged in.

1 Like

You need to put the phone in mass storage mode, sometimes called MTP. It’s in the settings. Once you do that it mount on your PC when you plug it in.

That assumes you have the passcode to unlock the phone, of course. If not, then it probably fell off the back of a truck and you should try to return it to its owner.


this, i think its in the pull down area at the bottom of the notification list?

1 Like

Thanks for all the answers. Apparently when I connected it the first two times nothing appeared in the notification area so I couldn’t figure out what I was doing wrong. Today it appeared and I just changed the connection from charging to MTP and all the folders were there.

Some phones are buggy as hell. Most of the time, I am unable to transfer files to/from my OnePlus2 from/to my PC. I have to excessively toggle USB Debugging in order to achieve this.

MTP is really buggy, especially on not MS Windows machines. Sometimes using adb push is better and will give you the errors encountered instead of just randomly unmounting the device or locking it up.

Need to unlock developer mode to do this though.

My phone isn’t found 9/10 times when connected to a PC, doesn’t matter whether it is Windows, Linux or Mac. And I’m rather optimistic with this value.

Yeah, I’ve had issues with MTP even on Windows machines quite a few times. I was trying to transfer a folder with just some pics and I just got the explorer.exe bell and no error, out of nowhere while just minutes before I transfered othern folders on this new phone. Weird.

@Azulath Haven’t had this issue really with any of my few smartphones but looks like tech is getting them harder to work outside of their own OS which is a bummer for me.

I’m assuming it’s Android, most Android phones use dmcrypt/LUKS for file encryption. So aslong as the phone is unlocked it should work. What’s probably the issue is that you need something that can understand MTP. Check out https://android.com/filetransfer that should help.

Thanks for the answer but the problem has been solved already and your solution is not applicable for me since I’m not using a Mac but a W10 machine.