Return to Level1Techs.com

(solved)Thunderbolt 3 Dock USB Issues with Windows 10

Hey there. First post and unfortunately I need help with a problem that I cannot seem to figure out my self…

I bought some hardware to do the “Linus” thing with a TB3 dock connected to the PC and place it in another room to get rid of the noise and heat, but for some reason I have problems with USB ports on the dock not being properly initialized under certain situations like doing a soft boot or the PC coming out of hibernation. Example if I have to change something in the BIOS, I have to do a cold boot, then save & exit from BIOS, turn off PC, and then boot up again. Else no USB peripherals will be detected.

Device drivers are installed properly, latest firmware for the TB3 card also up to date. No red or yellow markers on any devices in the device manager. Disabled the following: TB security in BIOS, ErP, Fastboot (also in Windows), “USB selective suspend” in the power plan. At this point I suspect something is going on with the TB3 dock, since by just doing a soft boot from within BIOS causes the USB not to initialize. I can’t see how this would even be related to Windows at all.

Hardware used:

Gigabyte X570 Aorus Master r1.1 @ BIOS version F20
Gigabyte Titan Ridge r1.0 TB3 card (latest firmware installed)
CalDigit TB3 Lite dock (refurbished unit)
Thunderbolt 3 active cable 2 meters
Alienware AW3418DW (using the 4 port USB 3.0 hub for my keyboard and mouse)
Sennheiser GSX 1000 USB soundcard (connected on separate USB port on the dock)
Anything else ask, but I didn’t think it would be relevant.

Edit: Switched over to the backup BIOS that’s running version F11. Everything works here. Seems I found a bug with version F20.