[Solved] SteamOS no signal

I'm trying to install SteamOS on my snes box, link here v
But I'm getting a "No Signal" on first boot.
I'm getting BIOS Splash screen and I even get the initial SteamOS logo, but after that nothing
I tried TAB+Space+Enter
I tried CTRL+ALT+ F1
and nothing on both
When I try CTRL+ALT+ F2
I get this

I don't know what to do from there

I had this problem before installing windows; everything would be fine up to the windows boot
the way I solved that was I went into SafeMode and uninstalled the generic display drivers and installed the Intel ones

I have no idea how to do that on linux

Can you get into a grub prompt. If you put a 3 at the end of the prompt you'll boot up into a terminal.


What GPU are you using, what display output style (HDMI, DP, DVI), which SteamOS installer?

I've had issues with the Valve remix of SteamOS, so I've used Stephenson's Rocket which gave much better results (read "actually worked") with both my R9 380 and my GTX 660 ti. No experience with intel iGPU, but I figure that would work best because of the quality of the intel drivers.

With your current issue set, as I understand it, my advice is to try the alternative image that I linked in the previous paragraph.

This absolutely looks like a GPU driver issue.

Intel iGPU, DVI-I analog (VGA adapter), SteamOS from Feb29 2016
I'm going to try your method and get back to you

Alright well that didn't work :/
I have one last thing to try before I go out and buy a 4x pcie to 16x riser to install a GPU and HOPE that I'll be able to use that to install the iGPU Intel drivers

Sounds good. Keep in mind that to keep your gpu within the constraints of the case, you may want to look into a PCIe ribbon cable. They're pretty awesome and I've got one in one of my systems.

If you have a monitor that's not VGA, try connecting it that way. I've seen issues before on these things with VGA adapters causing issues. I forget the workaround, but it's definitely worth checking that if you have the hardware.

I was using VGA because I wouldn't even get a bios screen using HDMI and I wouldn't see the login thing after pressing CTRL+ALT+F2 on DVI-I, VGA just had the best compatibility.

I found a fix though, going here http://repo.steampowered.com/download/
and downloading the alchemist DVDInstaller
This is SteamOS 1.0, but I now get a signal and can use SteamOS

Awesome! I'm glad you could find a solution.