Return to Level1Techs.com

[SOLVED] Skyrim on Steam Play, can't Dual wield

linux
skyrim
steam-play

#1

So my brother is running Linux (Ubuntu Mate 18.04) and is having a bit of an issue with with Dual wielding weapons and spells in Skyrim (Normal edition).
On Windows, pressing both left and right mouse buttons to attack with both hands works fine but doesn’t seem to do anything when running through steam play.
We’ve both tried finding the answer online but couldn’t find anyone else with this issue.
We’ve tried a different mouse already but the problem persists.

Does anyone know how to fix this? Thanks.

SOLUTION:
Turns out middle mouse button emulation is enabled by default on Mate. This means that a simultaneous right and left click is interpreted as a middle mouse button (Scroll wheel) click. Unfortunately, there is no option to disable this in the mate settings but can be disabled with a couple of commands.

Run:
xinput list to show device IDs. Example ouput:

⎡ Virtual core pointer                    |id=2|[master pointer  (3)]|
⎜   ↳ Virtual core XTEST pointer          |id=4|[slave  pointer  (2)]|
⎜   ↳ Logitech G403 Prodigy Gaming Mouse  |id=9|[slave  pointer  (2)]|
⎣ Virtual core keyboard                   |id=3|[master keyboard (2)]|

xinput list-props [id] where [id] is the id of your mouse. Example output:

$ xinput list-props 9
Device 'Logitech G403 Prodigy Gaming Mouse':
	Device Enabled (152):	1
	Coordinate Transformation Matrix (154):	1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
	libinput Natural Scrolling Enabled (286):	0
	libinput Natural Scrolling Enabled Default (287):	0
	libinput Scroll Methods Available (288):	0, 0, 1
	libinput Scroll Method Enabled (289):	0, 0, 0
	libinput Scroll Method Enabled Default (290):	0, 0, 0
	libinput Button Scrolling Button (291):	2
	libinput Button Scrolling Button Default (292):	2
	libinput Middle Emulation Enabled (293):	1
	libinput Middle Emulation Enabled Default (294):	0

xinput set-prop [id] [prop] 0 where [id] is the id of your mouse and [prop] is the id of the “Middle Emulation Enabled” property. Example:

$ xinput set-prop 9 293 0

This setting only stays until you log out/reboot. You may want to add it to your startup items in Desktop Environment’s settings.

Aparently this can also be done with:
gsettings set org.mate.peripherals-mouse middle-button-enabled false
But I didn’t test this.


#2

Do the mouse buttons work in the game’s menus, and/or does it persist in other games?

Maybe see what happens when you try reassigning the mouse buttons in the in-game settings?


#3

The mouse buttons work fine in the menus and by themselves. He hasn’t tried other games, he only has a few and I don’t think any of them use a simultaneous right and left click. I’ve looked through the menus and can’t seem to find an option to reassign this control.


#4

Out of curiosity, does the sound work all right in his game? When I try to play Skyrim with Steam Play, I get no music or voices.


#5

He says there is. I’m not sure what the solution to that is, sorry.