[SOLVED] Rocky Linux GUI problems after update and xrdp installation

Workstation specifications:
OS: Rocky Linux 8.7 (Green Obsidian) kernel 4.18.0-425.3.1.e18.x86_64
CPU: Ryzen Threadripper 3970X
GPU: RTX 3080 TI (x4)
Ram: 256 GB
Storage: 1x 4TB NVMe SSD (OS and software), 1x 2TB NVMe SSD (scratch), 120 TB HDD (Cold storage)

Background: My lab recently put together a workstation for processing and storing our data. Once the installation and setup were complete one of my colleagues wanted to install xrdp to remotely access the workstation. However, during the installation, they apparently “updated something” unintentionally. On boot, I can see the minimal boot screen on the display connected to the workstation. I can access the terminal via Ctrl + Alt + F2 or Ctrl + Alt + F3 and log in to the system but there is no GUI. If we log in to the system via xrdp we do have the normal Rocky Linux GUI but the colours for icons and software are displayed incorrectly.

I am not particularly advanced in my understanding of Linux, but this is what I have done so far with no success.

  1. Found the base environment using dnf group list –installed
    Output: Installed environment groups: Workstation
    Installed groups: Development tools, System tools.

  2. Checked the default target of the system.
    Checked with: systemctl get-default
    Output : multi-user.target

  3. Set it to graphical using: systemctl set-default graphical
    Checked with: systemctl get-default
    Output : graphical. target

  4. Uninstalling xrdp

  5. Checking if GNOME is installed
    Command: dnf list --installed | grep gnome
    Output: Long list of gnome stuff

  6. Switching to GUI mode by using startx and then Ctrl + Alt + F7

Can anyone explain please what is going on with this workstation? This situation has been nagging me for the past two days. I feel like there is a simple solution and explanation but I am just not seeing it.

No idea about Rocky Linux or Red Hat, but do you get a login screen? If not, try

systemctl start gdm.service

If that isn’t working

journalctl -u gdm

might give you a clue.


I solved my problem. The Nvidia drivers weren’t installed correctly during the update.

I figured this out after running journalctl -u gdm as MattiP suggested.

It spat out “GdmDisplay: Session never registered, failing”

I then looked at the Xorg.1.log and there were several errors concerning “Nvidia”

I followed this guide to remove and reinstall the Nvidia drivers properly and the system booted with the GUI after a restart.