Return to Level1Techs.com

[SOLVED] Remmina only allowing a single RDP Session

I’m having a weird Problem atm.
My current installation of Remmina only allows a single session to an RDP Windows Server.
The first connection after starting remmina works flawlessly. After that, any attempt to connect to something else over freerdp doesn’t work. Log:

[11:04:42:765] [6261:7487] [ERROR][com.winpr.sspi] - EncryptMessage status SEC_E_INVALID_TOKEN [0x80090308]
[11:04:42:766] [6261:7487] [ERROR][com.freerdp.core.nla] - EncryptMessage status SEC_E_INVALID_TOKEN [0x80090308]
[11:04:42:766] [6261:7487] [ERROR][com.freerdp.core.rdp] - rdp_recv_callback: CONNECTION_STATE_NLA - nla_recv_pdu() fail
[11:04:42:766] [6261:7487] [ERROR][com.freerdp.core.transport] - transport_check_fds: transport->ReceiveCallback() - -1
[11:04:42:766] [6261:7487] [ERROR][com.freerdp.core] - freerdp_set_last_error ERRCONNECT_CONNECT_TRANSPORT_FAILED [0x0002000D]
[11:04:42:766] [6261:7487] [ERROR][com.freerdp.core] - freerdp_post_connect failed
libfreerdp returned code is 0002000D

Any idea on what this could be?

As is so often the Case, i find my solution only minutes after posting here -.-


It seems to be a problem with the current freerdp Version. Since i’m on Arch, i was able to install the latest git version of freerdp through the AUR and this seems to have fixed my Problem.

Oh, interesting. I didn’t even look for a fix, I was hoping it would get fixed with an update. Also on Arch and it happens that I can only open 1 RDP connection, before I have to close Remmina entirely, then reopen it again to get another connection or even to reconnect to the same remote machine after closing the connection.

Sorry for bumping this post.

Using the freerdp-git from AUR solved it for me as well, thanks!